We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Current Aspose Version not compatible with license

My license indicates I cannot run the current version in the download page. How do I download a previous version (pre May 21)

Hi Larry,


Well, your license will never be expired if you use the API version whose release date is less than your license’s expiry date, it will work forever. If the current version/fix is released after your subscription expiry date then you need to upgrade your subscription. Please check subscription renewal policies for your reference:
http://www.aspose.com/corporate/purchase/renewal-policies.aspx

Second, you can download previous versions those are not older than one year. Please refer to the download page here: http://www.aspose.com/community/files/default.aspx

Please note that the latest version gives you the best quality. We always recommend our customer use the latest version as it includes a number of new features, fixes and improvements.

Please let us know in case of any comments or questions.