We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Custom threshold causing no reading

Hello Aspose,

We have correctly used your setting threshold guide to set our threshold. But when we set a custom threshold, no reading is achieved, and all the elements return empty values. When we tried it in your OMR template editor, it couldn’t read when we enter a threshold value less than 0.3. We suppose that by setting a threshold you mean, 0.1 => at least 10% of the selected area should be filled.

Find attached to this our sample template and image.

Thanks,
Hope
Hi Hope,

Thank you for your inquiry and providing sample files.

Yes! you got it correctly, 0.1 means at least 10% of the option area should be selected. We have tried to recreate the issue at our end. It was found that the issue persists. The issue has been logged into our issue tracking system with ID OCR-36021. Our product team will look into it. We will update you accordingly via this forum thread.

Furthermore it was also noticed that if we set the Threshold value to default settings, It will recognize and extract the answers.

Hello, any updates on OCR-36021?

Hi Hope,

This is to update you that we have evaluated the issue. Following are the details:
With threshold value as low as 0.1 (10%) all marks are recognized as filled. Marks are considered to be filled because even the empty mark circle takes about 26% to 30% of the area depending on area size, whereas actually filled mark takes about 60% to 70% of the area. Therefore, if threshold value is set less than 30%, all marks are recognized as filled. Sample images are attached showing the percentage for better understanding.

Furthermore it is the default behavior that grid elements with no multi-selection option on will return empty string.

Dear Ikram,

Thanks for replying. Your attached files really helped understand how the fill threshold works.
Hi Hope,

Thank you for the comments. Feel free to contact us in case you have any query or comments.

The issues you have found earlier (filed as ) have been fixed in this Aspose.Words for JasperReports 18.3 update.