We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Data entry problem - GridDesktop and French keyboard

Hi,


When entering numeric data using a french keyboard on cells winthin a GridDesktop control, the text of the first character appears as if the keyboard has US layout (e.g. 1 = !, 2=@, etc.). This only happens for the first character typed – subsequent characters are OK. Also, this only happens when using the standard number keys (first keyboard row) – using the numeric keypad works fine.

Hi,


Could you try our latest version i.e. v2.7.10.xxxx, you may download and install the full package and get the latest Aspose.Cells.GridDesktop assemblies:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry405613.aspx

If you still find the issue, kindly create a sample application, zip it and post it here. Also provide some screen shots of the issue and steps involved. We will check it soon.

Thank you.

Hi,


I’ve installed the new version but the problem persists. I can’t easily send you the application since it’s database-based, but it should be fairly easy to reproduce: using a french-layout keyboard, type in some numbers in a GridDesktop cell , you 'll see that the first character isn’t what it’s supposed to be. I’ve enclosed a screen grab showing what it looks like (the content of the cell should be “23”).

Cheers,

Henri

Hi,


Thanks for your screen shot.

We need to investigate your issue first. I have logged a ticket with an id: CELLSNET-41064 for your issue. Our concerned developer will analyze and look into your issue soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi,

Thanks for using Aspose.Cells for GridDesktop.

We have fixed this issue. Please download and use the latest version:
Aspose.Cells
for GridDesktop v2.7.11.2001


Let us know your feedback.

Hi,


The new version does indeed correct the issue. Thanks for the quick fix!

Hi,

Thanks for your feedback.

It’s good to know that your issue is resolved with this latest version.

Let us know if you face any other issue, we will be glad to help you.

The issues you have found earlier (filed as CELLSNET-41064) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.