We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Dates in pivot table not formated correctly?

Hi,


I was wondering if anyone else is getting a problem with pivot table when it contains a date column. When I have a pivot table set to be in tabular form and use Aspose.Cells to convert it to a pdf, the resultant pdf seems to have lost the date formatting. NOTE: I only seem to see this when working with excel 2007 installed.

I am currently attempting to recreate this in a smaller project in a machine with excel 2007 installed; Unfortunately I cannot recreate the problem in my normal test environment which has excel 2010 installed.

If someone could give some ideas about this, it would be great.

I will attach sample files soon.

Thank you.

Hi,

Thanks for your posting and using Aspose.Cells.

Please provide us your sample files, we will check your issue at our end. If we find any issue, we will log it in our database so that it could be fixed.

Hi,


I have attached a sample project that simply opens a file and re-sizes a source table, then saves it as two files called “generated file.pdf/xlsx”.

After further testing, it seems that the problem doesn’t occur when the source list object is not re-sized.

Please run the sample project and select the attached excel file “test67.xlsx” when the open file dialog box appears.

Thank you.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

Your sample project just generates the xlsx file and is not generating the pdf file. We have attached the generated xlsx file for your reference. Please provide us the sample project which also generates the pdf file so that we could check the issue at our end.

HI,


Sorry about that, I accidentally attached the wrong similarly named zipped file.

I have attached the correct zipped file now.

Hi,


Thanks for the updated sample project.

After an initial test, I can observe the issue after running your new project with your template file, the dates are rendered as numeric values in the output PDF, the dates are fine in the XLSX file though.

I have logged a ticket with an id “CELLSNET-41643” for your issue. We will look into your issue soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi,

Thanks for your posting and using Aspose.Cells .

We were able to notice this issue. Dates are not formatted correctly in generated pdf… We have also attached the output file for a reference. We have logged this issue in our database. We will look
into it and resolve it. Once the issue is resolved or we have some other
update for you, we will let you know asap.

Hi,


Thank you for your patience and for confirming the issue.

Hi,

Thanks for your posting and using Aspose.Cells.

Once, we will have some update for you, we will let you know asap. Thanks for your cooperation.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.3.2 and let us know your feedback.

Hi,


Thank you for the fix, the dates are not formatted as dates.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We were able to notice this issue. We have logged your comments inside our database. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

We have also attached the screenshot highlighting the problem in red circles.

Hi,


Thank you for continuing your investigation on this thread. I can’t seem to recreate the formatting bug in the latest Aspose.Cells version of 7.4.3.2 anymore.

However since you have generated a file already, could I point out that there is an extra empty column added to the pivot table (the “Date” column look longer).

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

It is good to know you do not have dates issue with the latest version. For empty blank column added into the output pdf, we have logged your comments. We will look into it and fix the issue. Once, we will have some update, we will let you know asap.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.3.3 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-41643) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.