We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Datetime issue in MSG


I am using Aspose.Email.dll (5.3) to work with MSG files.When I Load some MSG files in MAPIMessage what I observe that it doesn’t give me the correct date time.
In my one MSG file the Header contain the received date as

Received: by with SMTP id l5cs14016ibv;
Fri, 4 Jun 2010 03:14:49 -0700 (PDT)

when I load this MSG file in MAPIMessage and get the received date time as

f_MailObj.ReceivedDateTime = p_asposeMailObj.DeliveryTime.ToLocalTime();

my local time zone is (UTC-08:00) Pacific Time (US & Canada)

It gives me date time as 6/4/2010 3:14:49 AM

I am getting little bit confuse whether it should give me result as 6/4/2010 3:14:49 AM or
6/4/2010 2:14:49 AM

Shital Diwate


Thank you for posting your inquiry.

I would request you to please share your sample file with us so that we can analyze its date time information and investigate the issue in detail. We shall look into it and assist you further.

Hi Shital,

Thank you for providing the sample msg via email.

I have tested the MSG and observed the issue while displaying delivery time in local system time zone. This issue is logged under Id: EMAILNET-35039 for further investigation by the product team. I shall write here as soon as some feedback is received in this regard.

Hello Muhammad,

Is there any progress for EMAILNET-35039 ?

Shital Diwate

Hi Shital,

The issue is pending for analysis by our product team and an ETA is not available for it at this time. We shall update you here once there is some information available about this problem.

Hi Shital,

We have analyzed the issue in detail and tested it by changing our system timezone to (UTC-08:00) Pacific Time (US & Canada). It is observed that if we don’t switch OFF the “Daylight Saving Time” option, then the sample code shows wrong time. Therefore, it does not seem to be an issue with Aspose.Email but automatic adjustment due to this Daylight saving time option. You may please switch off this option while setting your system time zone, run the code again and let us know the feedback.