Free Support Forum - aspose.com

Decimal validations error

Hi!
I create validations of decimal type in my excel. On my development platform it works fine but on my customers profuction server I get an error (“Input string was not in a correct format.”).

The error occurs when using the following line
validation.Formula1 = "0.5"

If I change it to validation.Formula1 = “1” it will work fine, but I need the “0.5”. I have tried “0,5” as you would write it in swedish locale, but thet would give me a “Invalid formula in data validation settings.” error.

I have even tried a desperate (1/2).toString with no luck.

What should I do?

I don’t find this problem.

Which version of Aspose.Excel are you using? Have you tried the latest version at http://www.aspose.com/Downloads/Aspose.Excel/Default.aspx?

I am using the latest version.

The strange thing is that I don’t have the problem on my development machine, only on the production server on site at the customer (which I of course have no real access to…)

I will try to find out more about the settings on the server and will get back to you if I find anything interesting.

Thank you for your time!