Deployment to .Net 1.1


#1

Hi Tommy,

thanks you for your prompt response to our request. We downloaded hot fix and it solved all the problems for the moment. Not only that, we changed our code to use xml and transformations, which greatly improved performance. Currently, we’re facing another problem. We installed a test application, which uses the dll, on three computers, 2 XP Professional Stations and one Windows 2000 Server. All three were development boxes and had 2 versions of .NET runtime environment (1.0.375 and 1.1). Then we decided to try it on another box, which also runs under Windows 2000 Server, but never had .NET runtime installed before. We installed 1.1 .NET runtime and tried other applications, which don’t use asposepdf.dll. They all worked fine. The test application, which uses asposepdf.dll, partially runs, e.g. performs all unrelated operations such requesting data from SQL Server, it creates all necessary temp files related to transformations and fails when it comes to actually writing a PDF file on the hard drive. All permissions and other things related to security are OK, we ran all the checks and we can write other files to this directory. The only thought we have about all this is that the object was compiled under one of the older version of .NET or one of the betas, which we don’t have on the that box. If you could please let us know how it was compiled or simply compile a new version under 1.1 version or shed any light on that matter, we’ll greatly appreciate it.

Regards,

Nellie


#2


Dear Nellie,

Aspose.Pdf.dll is built with .Net 1.0.375.

Would you post or email to pdf@aspose.com the sample code as well as the detailed exception message thrown when running on .Net 1.1?

Thanks for your cooperation.