We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Difficulty Using Aspose.cells.jar

Hi,

We are getting the following exception while using the latest version of Aspose.Cells.jar (aspose-cells-7.2.0.jar) for Java 1.6

java.lang.NoSuchMethodError: com.ctc.wstx.api.ReaderConfig.doNormalizeLFs(Z)V
at com.aspose.cells.b.a.h.j.a(Unknown Source)
at com.aspose.cells.b.a.h.j.a(Unknown Source)
at com.aspose.cells.b.a.h.j.(Unknown Source)
at com.aspose.cells.b.a.h.j.(Unknown Source)
at com.aspose.cells.lG.a(Unknown Source)
at com.aspose.cells.lG.k(Unknown Source)
at com.aspose.cells.lG.a(Unknown Source)
at com.aspose.cells.lF.a(Unknown Source)
at com.aspose.cells.Workbook.a(Unknown Source)
at com.aspose.cells.Workbook.(Unknown Source)
at com.att.wireless.common.file.FileOperationManager.getAllRowsUsingAspose(FileOperationManager.java:150)
at com.att.wireless.care.bulk.web.BulkRatePlanFormHandler.handleFileUpload(BulkRatePlanFormHandler.java:459)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at atg.droplet.EventSender.sendEvent(EventSender.java:582)
at atg.droplet.FormTag.doSendEvents(FormTag.java:791)
at atg.droplet.FormTag.sendEvents(FormTag.java:640)
at atg.droplet.DropletEventServlet.sendEvents(DropletEventServlet.java:564)
at atg.droplet.DropletEventServlet.service(DropletEventServlet.java:591)
at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:135)
at atg.abtest.substituter.PageSubstituterPipelineServlet.service(PageSubstituterPipelineServlet.java:501)

I tried searching for this exception and got this response :
https://forum.aspose.com/t/118093

I am using the latest version for woodstox-core-asl-4.1.1, and on the following code we are getting this exception:

mInputStream = uploadedFile.getInputStream();
List mCTNs = new ArrayList();
Workbook mWorkbook = null;
try {
mWorkbook = new Workbook(mInputStream, new LoadOptions(LoadFormat.XLSX));
WorksheetCollection mWorksheets = mWorkbook.getWorksheets();

Exception is thrown on the above line which is underlined.
Hi,

Well, we think one possible reason for your issue is that you might has more than one woodstox-xxx jars in your environment. As you are running your application in a web scenario, so it is most likely that there is already another woodstox-xxx jar which is being used except the ones we provided in our release archive. We will further look into it and get back to you soon.

Thank you.

Hi,

For such kind of issue, we think the most possible reason is that there is another library for “com.ctc.wstx…”. Please check you server environment firstly to find the duplicated library out and if possible please replace it with the 4.1.1 version.

If the issue cannot be solved by this way, please give us more details about your environment, such as the server and version you used, how did you deploy your web application and so on so we can make further investigation.

Hi,
We are using Oracle Weblogic Bea, webserver, when i tried searching
for Woodstox i was able to find it in two locations with the name
"com.bea.core.woodstox_1.0.0.0_4-0-5" :

a)c:\bea\modules
b) C:\bea\wlserver_10.3\server\lib\wseeclient.zip

If the replace the above jar with the latest version of woodstox “woodstox-core-asl- 4.1.1”,
I am able to move ahead and everything works fine.

But I had a chat with Business team what they say is that they have
a problem with changing the jar in the BEA environment.

So is it possible that we don't have to change the jar in the bea and the
application searches for the new woodstox version in our own modules only
and don't take up the old version from bea.

note : We are using ATG Dynamo E Commerce Framework.
Hi,

For such kind of issue, we think you’d better to contact with the support team of weblogic server to confirm whether you can get one of following solutions:
1. Upgrade the woodstox library of weblogic to newer version.
2. Let weblogic load the woodstox library from your application’s WEB-INF/lib instead of loading it from the default position.
Another possible solution from our end is we try to avoid to call those APIs that old version of woodstox does not support when we find the loaded woodstox library is some old versions. However, we cannot make thorough test to check whether this change may give some unexpected result. If you want to try this solution, we will try to provide you a fix soon.

Since making a change in the weblogic environment is strictly forbidden( for obvious reasons that it is being used by everybody in the project). If you can provide some solution from your end in which old version of “woodstox” is not referred, it would be really helpful.

Hi,

We have forwarded your issue to development team and logged this issue in our database.

We will look into your problem and give you advice asap.

This issue has been logged as CELLSJAVA-40190.

Hi ,

I am unable to login to JIRA to check the status of my issue, it seems it requires a different username and password for login. Can you please provide me with an access to it?

Hi,

You cannot access JIRA issue. It is for our internal discussion with development team.

However, when we release the major version, we also publish these JIRA ids that mention which of the issues have been fixed.

Also, we keep track of your issue with these JIRA ids.

Whenever your require some update or need to provide further information, you can post on your thread and we will provide you update and log your information.

Please see the sample release notes at the following link. I have also attached the screenshot for your reference.

Release Notes - Aspose.Cells for .NET 7.2.1

Screenshot:

Hi,

Please download and try the latest fix: Aspose.Cells for Java v7.2.1.4

We have disabled the unsupported method invocation for old woodstox versions. Please try this new fix to check whether it can work with your environment.

Hi ,

The above provided version is working fine for us, but what we need now is the technical details regarding what you guys changed in the Current Aspose.cells, because the version provided by you is an evaluation version(if i am not wrong), and our architect needs to get in touch with your business team to obtain the licensed version of the same.

PS:We already have the latest license for Aspose Total.

Thanks for your support!

Hi,


We will soon get back to you if we can provide technical details for your issue.

Regarding your other query, well, all the versions/fixes of the product would be evaluation versions if they are not used with a valid license or you do not use/set your valid license file in your code with the fix/version. The evaluation version will simply become professional when using/setting the license in your code.

See the document for your reference:
http://www.aspose.com/docs/display/cellsjava/Licensing

Let us know if you still have any confusion. We will happy to assist you.

thank you.

Hi,

Please also note down that if you have latest license of Aspose.Total for Java, then you can use it with this version and you can use it with every new version till it’s date of validity does not get expired.

Suppose your license expires in August 2012, then you can use all the new releases till August 2012, after that you will have to renew your license subscription.

You can view your license’s expiry date by opening your license in a notepad.

The issues you have found earlier (filed as CELLSJAVA-40190) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.