Free Support Forum - aspose.com

Disabling AutoFormat While Saving

Hi,

I am Developing Report for a European Client for Whose the Decimal Delimiter is a Comma.If the Number\Cell Value is in the form of String like “110,55” After exporting to excel it Adds extra zeros at the end and makes it 110.55,00.which I think may be due to autoformatting in excel.Do you have any Property/Which can disable the Auto Formatting for a particular Column ?

Please Reply me to the earliest.
Regards,
Chaitanya

Hi,


Could you please try to specify the region and language settings accordingly (for your locales) before saving to Excel file format. e.g
workbook.Settings.Region = CountryCode.;
workbook.Settings.LanguageCode = CountryCode.;

Let us know if it works fine.

Thank you.

Hi Amjad,

Thanks for your prompt reply.
Yes tried this too but its not working.
I want the numeric string to be treated as String and not Number.

Regards,
Chaitanya

Hi,


Well, MS Excel will display data / contents in the file according to the locale/regional settings for your machine where you are opening the file. Please make sure that the language and regional setting for the OS is your desired European settings. If you still could not evaluate, kindly give us two files: an excel file (output file) generated by Aspose.Cells, your desired file with your desired formatting set for the data. We will check it soon.

Thank you.


Hi,

Here are the two files.

Hi,

Here are the two files.
The Delimiter as per Format is ‘,’ and group separator is ‘.’ as per European number format.

Regards,
Chaitanya

ChaitanyaW:
Hi,
Here are the two files.
The Delimiter as per Format is ',' and group separator is '.' as per European number format.

Regards,
Chaitanya

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

It actually depends on your machine Language, Date & Regional Settings. If your machine has European (say German) settings, it will display the number 122113 as 122.113,00

However, if your machine has United States (English) settings, it will display the number 122113 as 122,113.00.

Please see the following screenshot for your reference. I have also attached the source xlsx file used in this screenshot.

Screenshot: