Free Support Forum - aspose.com

DisplayZeros option is not carried through to xml output

Hello,

Excel has an option to not display zero values (Tools -> Options -> "Zero values" checkbox, or Excel Options -> Advanced -> "Show a zero in cells that have zero values" checkbox (Excel 2007)).

When I uncheck the checkbox on my Excel sheet, I can save from Excel in xml format and the setting is retained. I can load the Excel sheet into Aspose, and the setting is retained if I save from Aspose to xls format. If I save from Aspose to xml format, the setting is not retained.

I'm attaching an Excel sheet, and the two xml outputs that illustrate this. It's not a high priority for us, but it would be nice if the setting were retained.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

<![endif]–>

Hi,

Thank you for considering Aspose.

We have found your mentioned issue after an initial test. We will look into it and get back to you soon. Your issue has been registered in our issue tracking system with issue id CELLSNET- 12059.

Thank You & Best Regards,

Hi,

Thank you for considering Aspose.

Please try the attached latest version of Aspose.Cells. We have supported DisplayZeros option in XML file.

Thank You & Best Regards,

The issues you have found earlier (filed as CELLSNET-12059) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.