Doc compare fails

Trying to do a document comparison using the first code example on this page (, I get an “Object reference not set to an instance of an object” error. Both documents are attached.Document1.docx (20.3 KB)
Document2.docx (31.3 KB)

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): WORDSNET-25036

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.

Thank you. Out of curiosity, I tried doing an online doc compare and I got the exact same error (image of code attached).

@joe_lopez This is expected, since Cloud version of Aspose.Words uses on-premises version of Aspose.Words as back-end.
By the way, the issue is already resolved in the current codebase and the fix will be included into the next 23.3 version of Aspose.Words. We will be sure to let you know once it is released.

Of course. I tried the Cloud version mostly to confirm the issue wasn’t with something I’d done using on-prem but also to try it out for the first time. Very slick.

Thank you for resolving this so quickly.

1 Like

The issues you have found earlier (filed as WORDSNET-25036) have been fixed in this Aspose.Words for .NET 23.3 update also available on NuGet.