We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

DOC/DOCX output vs. PDF output

Hi Aspose-Team,

I´m using Aspose Words to fill several Word templates via Mailmerge with data. When I compare the resulting PDF with the DOC/DOCX files the formating of my first table seems to be lost.

Whats wrong here? To clarify what I mean I attached the results, and the template which is used.

kind regards

Hi
Uwe,


Thanks for your inquiry. I think, you can call UpdateTableLayout method before exporting to PDF (or any other fixed-page format), only in rare cases where you confirmed that tables appear incorrectly laid out in the output document. I hope, calling this method will help to correct the output.

If we can help you with anything else, please feel free to ask.

Best Regards,

Thanks for your quick reply!

I called UpdateTableLayout and the result looks better now, but unfortunately not perfekt. The last two columns are wrapped, but they shouldn´t. Why is Word not wrapping them?

kind regards

Hi Uwe,


Thanks for your inquiry. Could you please tell us which version of Aspose.Words are you currently using? The latest version of Aspose.Words is 10.8.0; in case you’re using an older version, I would suggest you please visit the following link for downloading and using the latest version of Aspose.Words and let us know your findings then:
http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/default.aspx

I hope, this will help.

Best Regards,

I´m currently using version 10.7.0. I already tried version 10.8.0 but faced some problems with image mergefields. After merge the field for the image will not be removed ( with CleanupOptions set to RemoveUnusedFields).

The result will be the same for the table. Can you reproduce the table behavior with the samples I send you?

kind regards

Hi Uwe,


Thanks for your inquiry. While using the latest version of Aspose.Words i.e. 10.8.0, I was unable to reproduce this issue on my side. Moreover, I have attached the PDF file i.e. generated on my side here for your reference. Also, as mentioned earlier, I would suggest you please upgrade to the latest version.

As far as the problem, you’re getting with Image merge fields, is concerned, it is a known issue with Aspose.Words v.10.8.0 and has been fixed now. Your request has been linked to this issue and you’ll be notified at the end of this month once the new version of Aspose.Words i.e. 10.9.0 is released.

If we can help you with anything else, please feel free to ask.

Best Regards,

The issues you have found earlier (filed as WORDSNET-5747) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(56)