Free Support Forum - aspose.com

Document not displaying signature images

We create documents with signature images, and save the document to a database as a byte array. We then later need to load the document and display it.
Using an older version of Aspose.Words (product version 2012.09.30, file version 11.8.0.0), this worked correctly.
Now using Aspose.Words 18.1 the signature images do not display.
If I save the byte array as a file and open using MS Word, the signatures display correctly.
Is this a bug in how the Aspose.Words Document class now processes this byte array?
Or are there changes is how I need to load the byte array into the Document object?

I should also note, I tried version 18.6, and the same issue is still present.

@mdgumby,

Thanks for your inquiry. To ensure a timely and accurate response, please ZIP and attach the following resources here for testing:

  • Your input Word document
  • Aspose.Words generated output DOCX file showing the undesired behavior
  • Please create a standalone simple console application (source code without compilation errors) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we will start investigation into your scenario and provide you more information. Thanks for your cooperation.

I have attached a ZIP file containing the following:

  • “agreement template 3 105211.dot” - a template file with merge fields used with Aspose.Words 18 to create a Word document
  • “agreement_20180621_062401.doc” - the document that was created from the merge (in it you can see the signature images)
  • “TestAspose” - folder containing a C# solution used to input that Word document and use Aspose to convert to a JPEG format
  • “agreement_20180621_062515.jpeg” - output of the Aspose JPEG conversion (in it you can see that the signature images do NOT appear)

Please let me know if you need more information.

@mdgumby,

I am afraid, we do not see any attachments in this thread.

You can also upload the ZIP file to Dropbox and share the Download link here for testing.

I uploaded to Google drive. Link is: https://drive.google.com/open?id=14LsJkC6EVsGL5gkJ3jRlqS-lXOCTpbZN

@mdgumby,

Thanks for your inquiry. We tested the scenario and have managed to reproduce the same problem on our end. For the sake of correction, we have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-17052. We will further look into the details of this problem and will keep you updated on the status of correction. We apologize for your inconvenience.

are there any updates to this? It is critical we get resolution, as we need the latest Aspose changes to correct a different customer bug. If there won’t be a resolution coming, we may be forced to look at alternative products.

@mdgumby,

Unfortunately, your issue is not resolved yet. This issue is currently pending for analysis and is in the queue. We will inform you via this thread as soon as this issue is resolved. We apologize for your inconvenience.

Can I please get an update on this? It has been 1 month since the last update from you.

@mdgumby,

The fix of this issue is included in 18.8 version of Aspose.Words. Please upgrade to the latest version from the following link. Hope this helps.
https://www.nuget.org/packages/Aspose.Words/

The issues you have found earlier (filed as WORDSNET-17052) have been fixed in this Aspose.Words for .NET 18.8 update and this Aspose.Words for Java 18.8 update.