We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

DocumentBuilder.insertHtml() fails with ExceptionInInitializerError/NullPointerException running in Oracle 11g JVM

We use Apose.Words running in the database, using its own internal JVM. This has worked successfully for many years.


We are considering upgrading from Aspose 13.10 to 14.12 - but are experiencing an error while rendering mailmerge fields as HTML.

Database Version: 11.2.0.4.0
JVM Version: 1.5 (within Oracle database).
Aspose version: 14.12 - this is the latest version that supports JVM 1.5, which is the version inside the database.

The test case (see below) works fine for Aspose.Words 13.10.

Could you please offer any advice?

My initial thoughts are that this could have something to do with fonts. Has the was HTML being rendered changed between 13.10 and 14.12?

Thanks.

SQL> create or replace and compile java source named testasposewords as
2 import com.aspose.words.Document;
3 import com.aspose.words.DocumentBuilder;
4 public class TestAsposeWords
5 {
6 public static void test() throws Exception
7 {
8 Document doc = new Document();
9 DocumentBuilder builder=new DocumentBuilder(doc);
10 builder.insertHtml (“

Hello

”);
11 }
12 }
13 /
Java created
SQL> create or replace procedure Test_Aspose_words
2 AS LANGUAGE JAVA
3 NAME ‘TestAsposeWords.test()’;
4 /
Procedure created
SQL> set serveroutput on
SQL> exec dbms_java.set_output(1000000);
PL/SQL procedure successfully completed
SQL> exec Test_Aspose_words;
Exception in thread “Root Thread” java.lang.ExceptionInInitializerError
at com.aspose.words.zzZWQ.(Unknown Source)
at com.aspose.words.zzZV3.zzQ0(Unknown Source)
at com.aspose.words.zzZVB.zzZ(Unknown Source)
at com.aspose.words.zzZVB.zzY(Unknown Source)
at com.aspose.words.zzZVB.zzZ(Unknown Source)
at com.aspose.words.zzZTV.writeText(Unknown Source)
at com.aspose.words.zzZTV.zzZ(Unknown Source)
at com.aspose.words.zzZTV.zzP(Unknown Source)
at com.aspose.words.zzZTV.zzQ(Unknown Source)
at com.aspose.words.zzZTV.zzP(Unknown Source)
at com.aspose.words.zzZTV.zzQ(Unknown Source)
at com.aspose.words.zzZTV.zzP(Unknown Source)
at com.aspose.words.zzZTV.zzQ(Unknown Source)
at com.aspose.words.zzZTV.zzZ(Unknown Source)
at com.aspose.words.DocumentBuilder.zzZ(Unknown Source)
at com.aspose.words.DocumentBuilder.insertHtml(Unknown Source)
at TestAsposeWords.test(TESTASPOSEWORDS:9)
Caused by: java.lang.NullPointerException
at asposewobfuscated.zzLP.zzJg(Unknown Source)
at asposewobfuscated.zzLP.zzJf(Unknown Source)
at asposewobfuscated.zzTN.(Unknown Source)
… 17 more
begin Test_Aspose_words; end;
ORA-29532: Java call terminated by uncaught Java exception: java.lang.ExceptionInInitializerError
ORA-06512: at “SC.TEST_ASPOSE_WORDS”, line 1
ORA-06512: at line 2
SQL>

Hi Jonathan,

Yes, there are many changes between 13.10 and 14.12. Please check http://www.aspose.com/docs/display/wordsjava/Migrating+from+Earlier+Versions+of+Aspose.Words for public API changes.

Can you please also test with a version older than 14.12 e.g. 14.5 or 14.7 and let us know if it throws the same exception?

Best Regards,

Thanks,


I tested with 14.8 (the earliest version I could download) - and I can confirm this DID work.

I will work my way back from through versions (14.11, 14.10, 14.9) until I find the latest version that works, and I will get back to you.




Hello,


I can confirm that the latest 14.X version that works is 14.10.

As mentioned before 14.8 also worked.
I haven’t tried 14.9, but assuming this also works - it looks like the issue manifested in version 14.11.

As a workaround, we can stick with version 14.10…

However, when we upgrade to Oracle 12c, we would probably like to go to the latest 15.X version - so it would be nice if this problem was fixed there.
I don’t have access to a 12c database at the moment - but when I do, I will try it out.

Hi Jonathan,

Thanks for the update and your assumption was correct, it was a font issue. GenBasR.ttf was present in the resources folder of older versions and it was being used as the default font. Later it was removed and there was no font in some releases.

After that Fanwood.otf was included in the latest versions and latest versions use it as default font. Looks like you will not be able to use any release which does not have a font. To work around it, you can copy GenBasR.ttf from older versions in 14.12 to get it working.

Best Regards,

Hello,


I was happy to stay with 14.10, but for other reasons - I am looking at 14.12 again.

I notice that 14.12 DOES contain GenBasR.ttf (in the jdk15 version) - so this can’t be the reason.

Hi Jonathan,

Is not it possible for you to use 15.X versions? You will not see this issue with the latest versions.

Best Regards,

11g is stuck on JVM 1.5 - it can't be changed.
15.X is for Java 6+.

We are not planning to upgrade to Oracle 12 (JVM6 and can be upgraded) until next year.



Hi Jonathan,

We are investigating the issue in detail and will update you soon.

Best Regards,

Hi Jonathan,

It will not be possible for us to fix the issue in the older version (14.12.0) however a new issue to provide JDK 1.5 specific build for latest version has been logged into our issue tracking system as WORDSJAVA-1188. We will keep you updated on this issue in this thread.

Best Regards,

Hi Jonathan,

JDK 1.5 support has been dropped by Oracle so it is not supported by latest versions of Aspose.Words also. We are sorry to share that it will not be possible for us to resolve any issue for JDK 1.5.

Sorry for the inconvenience.

Best Regards,

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan