We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does “Aspose.Pdf” Version=“21.12.0” support .Net 6, .Net 5, .Net Framework 4.7.2+ and NetStandard2.0 frameworks on Windows & Linux platforms?

Does “Aspose.Pdf” Version=“21.12.0” support
.Net 6, .Net 5, .Net Framework 4.7.2+ and NetStandard2.0 frameworks on Windows & Linux platforms ?

@sreenath.techie

Aspose.PDF does support .NET Framework, .NET Standard and .NET 5. Please read more detail from here:
System Requirements

We logged a ticket as PDFNET-50918 to test Aspose.PDF functionality under .NET 6.0 in Windows and non-Windows environments. We apologize for your inconvenience.

@tahir.manzoor In supported frameworks list https://docs.aspose.com/pdf/net/system-requirements/#supported-frameworks .Net 5 is not mentioned.
Also, may I know tentative date of .Net 6 testing completion?

@sreenath.techie

Aspose.PDF does support .NET 5.0. However, it is not mentioned in the article. We will update the documentation.

@tahir.manzoor

  1. Does all of them support both Windows and Linux platforms?
  2. May I know tentative date of .Net 6 testing completion and when it will be available?

We are activity working on POC to decide on PDF library to purchase for our products.

@sreenath.techie

A ticket with ID PDFNET-51089 has been created in our issue tracking system for further investigate on it.

Currently, this issue is pending for analysis and is in the queue. Once we complete the analysis, we will then be able to provide you an estimate.