Free Support Forum - aspose.com

Does aspose.powerpoint have a max file size

I am trying to work on a 1.6mb ppt file, with approx 98 slides.
However the file gets modified with aspose, but cannot be opened in powerpoit after. I did have it working with smaller files, but now has stopped.
If I use the code below(which should do nothing other than load & stream the file for saving) I still get the same error.

I guess it may be file size, any one had experince with this

Thanks in advance for any help

Garry

Code--------

Imports Aspose.PowerPoint

Public Class WebForm2

Inherits System.Web.UI.Page

Protected WithEvents Button1 As System.Web.UI.WebControls.Button

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

'Dim license As Aspose.PowerPoint.License = New Aspose.PowerPoint.License()

'license.SetLicense(“Aspose.PowerPoint.lic”)

Dim fis As System.IO.FileStream = New System.IO.FileStream(MapPath(".") + “\user\userdata\files\tuesday.ppt”, System.IO.FileMode.Open, System.IO.FileAccess.Read)

Dim pres As Presentation = New Presentation(fis)

fis.Close()

Me.Response.ContentType = “application/vnd.ms-powerpoint”

Me.Response.AppendHeader(“Content-Disposition”, “attachment; filename=testppt.ppt”)

Me.Response.Flush()

Dim st As System.IO.Stream = Me.Response.OutputStream

pres.Write(st)

Me.Response.End()

End Sub

End Class

Dear Garry,

Aspose.PowerPoint doesn’t have any limitations on file size. At least I tested it with presentations up to 30mb and more than 500 slides.

Did you try to save it directly to the file (without using response)?
If you will have the same problem can I ask you to send me this file for investigation?

Hi Alexey

Thanks for that
I have forwarded via email the a zipped version of the powerpoint & await your reply

Thanks again

Garry

Hi Alexy

Did you get the email I sent ?

Garry

Hi Alexey

Haev you been able to out this problem from the file I emailed.

I havent seen any reply yet.

Your ideas would be appreciated

Thanks

Garry

Dear Garry,

I’m sorry but I didn’t get files. Attachment was broken.
I sent you email back and asked to resend files to tyumen@aspose.com

Hi Alexey

Sorry I did not get you email, I have just sent a second file , hope you get that ok

Regards

Garry

Dear Garry,

Please check 1.7.13 hot fix. It was a problem with numbered bullets.

Hi Alexey,
Thanks that hot fix fixed the problem.
Great support.
Now I only have to find out where in my code I have an error referencing main.masters & I am all set to go.

Thanks for the help again

Regards

Garry