We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does the Aspose library support Azul OpenJDK 11

Please confirm if Aspose library support Azul OpenJDK 11 ?

@luhtms

Would you please also specify which Aspose API are you using? e.g. Aspose.PDF, Aspose.Words, etc.?

For APIs we use Aspose.Email and Aspose.PDF

As for versions with Java 8 we use: aspose-email-17.7-jdk16.jar, aspose.pdf-16.12.0.jar

@luhtms

Both APIs support OpenJDK 11. However, you need to use the latest available versions of them in order to use them with OpenJDK11. In case you face any issues, please feel free to let us know.

Please confirm what is the latest available version for the aspose-email and aspose.pdf jars.

We are using aspose-email-17.7-jdk16.jar, aspose.pdf-16.12.0.jar, do these version support OpenJDK 11 ?

@luhtms

These are quite older versions of the APIs and we are afraid that they do not have support for OpenJDK11.

Below are the latest available versions of these APIs:

Thanks for the response.
One last question.
Does the latest versions of these libraries require an updated license ?

@luhtms

You can check expiry date of your license file by opening it in any text editor. The date can be seen inside <SubscriptionExpiry> tag. If it is greater than the date when latest version of the API was released, you can use it. In other words, a license can be used with any version of the API released within the date of expiry of the license.