Free Support Forum - aspose.com

Doesnot support .Net Framework runtime v4.0

Hi,

Is there a way that Aspose.Words.dll will work on a system without .NetFramework 2.0?

By default window 8.1 does not include .NetFrameswork 2.0, So some of out customers have difficulty in using our application to view documents.

Do we have Aspose.Words.dll for runtime v4.0 or Any work around to deal with this situation?

Please suggest.

Thanks,

Robert

Hi Robert,

It is recommended to install .NET 2.0 even if you are using .NET 4.0. If you do not want to install .NET 2.0 in any case, then please let us know and we will log a request to share Aspose.Words.dll which is built on .NET 4.0 with you.

Best Regards,

Hi Muhammad,

We will need the Aspose.Words.dll which is built on .Net 4.0 runtime, since we are supporting our product in a fresh win 8.1/10 system with logged in user who do not have a privilege to install the .Net 2.0. Kindly send us the dll ASAP, so that we will resolve our customer need soon.

I would also recommend to consider adding the dll built on .Net 4.0 in every release so that other users may also have a similar situation.

Thanks,

Robert

Hi Robert,

Thanks for the details. A request to provide .NET 4.0 DLL has been logged into our issue tracking system as WORDSNET-12329 and has been forwarded to our product team. We will let you know as soon as it is ready.

Best Regards,

Hi Robert,

.NET 4.0 DLL will be part of Aspose.Words for .NET from upcoming release.

Best Regards,

Hi Muhammad,

Thank you for considering our request, we will fix our software to support for both .Net 2.0 and 4.0.

Thanks,

Robert