We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Dot (.) Changed to Comma (-) in =Text Formula

We have an Excel cell that contains:
=TEXT(“31.12.2014”;“TT.MM.JJJJ”)
The cell format is text or standard (doesn’t matter).
When I get the cell value, the string is:
“31,12,2014”
So comma instead of dot!

We use Aspose.Cells 8.2. The same sample works correctly with Aspose.cells 7.7.2.0

Please help and best regards
Christian

Hi,


Thanks for providing us some details.

Could you provide us your template Excel file here, we will check it soon.

Thank you.

Please see cell A2 in the attached file.

Hi Christian,


Thank you for providing your sample spreadsheet.

We have evaluated your presented scenario while using the latest version of Aspose.Cells for .NET 8.2.0.3, and have received expected results with the following piece of code. Attached is the snapshot of my console showing the dot (.) instead of comma (,).

C#

Workbook book = new Workbook(“D:/temp/ExcelDatum.xlsx”);
Worksheet sheet = book.Worksheets[0];
Console.WriteLine(sheet.Cells[“A2”].Value);

Please give a try to the latest version (link shared above) and let us know of you feedback.

Aspose.Cells 8.2.0.3 produces the same result as 8.2:
The sample works correctly on a Windows 8 Laptop. But fails with “31,12,2014” on a Windows 2008 Server in an asp.net web application.

Hi Christian,


Thank you for writing back.

We are sorry that the latest build didn’t help in your scenario. We have logged an investigative ticket in our bug tracking system to look further into this matter. The ticket Id for your future reference is CELLSNET-42990. Please spare us little time to isolate the problem cause on our end.

We will thoroughly investigate the matter, however, we think that the problem is related to the region settings. You can check this by changing the region of your Windows Server 2008 platform to the one set on your laptop.

Dear Aspose Team



The region settings on both machines are German (de-DE). That was the first thing I checked.



The problem occures when WorkBook.CalculateFormula(); is called.



So please change your code to:





Workbook book = new Workbook(“D:/temp/ExcelDatum.xlsx”);


book.CalculateFormula();


Worksheet sheet = book.Worksheets[0];


Console.WriteLine(sheet.Cells[“A2”].Value);





Run this on a Windows Server with culture {de-DE}, you should be able to reproduce the problem.


Please reply shortly, we need this funktionality to work correctly.


Best regards


Christian

Hi Christian,


Thank you for checking the locale of your Windows Server 2008 platform. As discussed earlier, we have made a request to the core development team to investigate the matter in order to isolate the problem cause, and to provide a fix. Please spare us little time to setup the required environment as well as to analyze the issue. In the meanwhile, we will keep you posted with updates in this regard.

We are sorry for the inconvenience caused to you.

Hi,


Sorry for the delay.

We fixed the issue since the release of Aspose.Cells for .NET v8.2.1, so, you may try it or use our latest version/fix: Aspose.Cells for .NET v8.3.1.1

Let us know your feedback.

Thank you.