Free Support Forum - aspose.com

Embedded PPT file gets broken after updating it

Hi Team,

I have recently run into an issue regarding embedded objects in Excel. I have some .xlsx files with different embedded objects in it.

  • embedded .xls file
  • embedded .doc file
  • embedded .ppt file

I can collect, edit and re-insert all of them into the .xlsx file, however when I want to open or save the updated objects from the root document, I cannot manage to do that with the .ppt file (it seems broken), while the others work fine.

Tried on Windows with the latest stable Aspose DLLs.

I attached a sample project in a zipped folder with the documents I tried to process and the output documents as well. You just need to run the application in console and give the licence and input file paths as arguments. It will generate the output file to the same location where the input file is.

I have already experimented a bit meanwhile with the application I attached and would like to share my experience with you:

  1. When I do not process the embedded PPT object with Aspose.Slides, just save the object from Excel to stream and insert that stream immediately back to the Excel workbook, the embedded PPT can be opened in the result workbook. However, if I just load and save it with Aspose.Slides using the corresponding loadformats and saveformats (without writing something to the embedded file or any modification), it gets wrong.
  2. Also, I managed to save the embedded PPT from the document to disk after it had been loaded and modified with Aspose.Slides and it could be opened successfully as a standalone file. Maybe there is something wrong with saving the embedded PPT object to stream?

I would be grateful if you could help me.

Thanks in advance,
Tamas Boldizsar

embedded_ppt_gets_broken_after_update_in_excel.zip (134.4 KB)

@tamas.boldizsar,
We have observed the issue and logged it in our database for further investigation. You will be notified here once any update is ready for sharing.

CELLSNETCORE-111-Embedded PPT file gets broken after updating it

@ahsaniqbalsidiqui

Thank you! I am looking forward to hearing from you soon.

@tamas.boldizsar,

Sure, once we figure it out, we will update you here.

1 Like

@tamas.boldizsar,
This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@ahsaniqbalsidiqui

Thank you for the very quick answer and fix! Great work, I am very grateful. I cannot wait getting the fixed version.

@tamas.boldizsar,

You are welcome. Hopefully the fix will be shared before the end of this week.

1 Like

@tamas.boldizsar
Please try the latest fix 21.4.2.
Aspose.Cells21.4.2 For .NetStandard20.Zip (5.5 MB)

@simon.zhao

Thank you! Unfortunately I could not try the fixed version on my machine using the sample project I attached earlier.

Warning message: “warning MSB3277: Found conflicts between different versions of “System.Drawing.Common” that could not be resolved. These reference conflicts are listed in the build log when log verbosity is set to detailed.”
Error message: “Could not load file or assembly ‘System.Drawing.Common, Version=4.0.0.1, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’. The located assembly’s manifest definition does not match the assembly reference. (0x80131040)”

I added the fixed DLL to my project as a reference (Dependencies/Assemblies), and also Aspose.Slides.NET as a NuGet package (Dependencies/Packages).

I assume that the reason for the error may be that both DLLs have a dependency on System.Drawing.Common, but on different versions: it is 4.0.0.1 for Cells and 4.5.0+ for Slides if I am not mistaken. I have experimented with assembly ridirection, but no results.

Could you please provide me a way for trying the fix successfully?

@tamas.boldizsar,
Please try to download the sample project here that contains the above shared hot fix and runs fine.

@ahsaniqbalsidiqui

Thank you for the sample project! I have tried it, but I did not succeed unfortunately.

First, I tried to simply run it without build, but the Cells DLL hintpath in the .csproj file was wrong. Therefore, I had to modify the hintpath and then build and run the project. After that, I got the same assembly error that I mentioned above.

Any other suggestions?

@tamas.boldizsar,
I have tried again in Windows and simply added this latest hot fix manually to your project in the first post. No issue is observed and it worked fine without any references problem. However for further investigation, I have logged your concern with the ticket. We will discuss this issue in details and share our feedback soon.

CELLSNETCORE111.png (20.6 KB)
Hi @tamas.boldizsar
Please try the configuration shown in the figure:
system.drawing.common 4.7.0
system.Text.encoding.codepages 4.7.0
Manually reference the two libraries, using 4.7.0 version.