Free Support Forum - aspose.com

Error exporting to word

I am getting an error when trying to export it to a Word Document. The bottom three options work fine. I also checked/verified that the configuration (rsreportserver.config) file was set correctly which I think, it is because I see the 4 options from Aspose.

Please let me know who I should get hold of in order to fix this issue.


This message was posted using Email2Forum by Merit. (attachment)

Can anyone help, please? Attached is a screen shot of the error message on the server.

DmitryV will try to help you. I think he will be back from holidays tomorrow.

Hoping DimitryV is back. Need assistance please!

Hi,

Thank you for your request and sorry for delay. From what I can see from your screenshot, the E:\MSSQL\MSSQL.3\Reporting Services\ReportManager\web.config file has been modified to enable custom errors. Could you please try to change the value of the mode attribute from on to On (capitalized, as the error message suggests?). Then please let me know what happens.

I'm looking forward to your response.

Thanks for the response but now I am onto a second error. Have attached the screenshot below.

The problem apparently has to do with your web.config file that is being edited incorrectly. Please follow the instructions provided by the error message and the problem should disappear.

Also, could you please attach the report you are trying to render? I'll then test it to verify it works.

Thanks.

The only editing I have done is change the lower case ‘on’ to upper case ‘On’. Also tried setting the CustomErrors property to ‘Off’ and that is the error screenshot I posted previously. As for the reports, all or any report when trying to export to Word gets an error message. But the other three options from Aspose works fine such as the RTF, XML and DOCX formats. I have inluded below the Web.config file ( I just changed the extension to be txt).

Here is an RDL for one of our reports that we tried exporting to Word via Aspose.

Any updates on this one?

Yes, I have tested your report and it was perfectly exported to the DOC format without any issues.

Please find attached, this is the web.config file from my machine. Try to temporarily replace yours with it and let me know if the error disappears.

Thanks.

I replaced my web.config file with yours and it is still giving me the same error message. I am still not able to export out to DOC format.

  1. Are you using the latest version of Aspose.Words for Reporting Services?
  2. Are you running the export on 32-bit or 64-bit system?

Yep, I downloaded the latest version which was 2.0.3.0 for reporting services.

The reporting services is being hosted off of a 64 bit machine.

The error you have reported is a known issue we've been struggling against for a while. It only occurs on 64-bit systems (that's why I asked you about that) and we suspect it might have to do with obfuscation. Please find attached, this is a build of Aspose.Words for Reporting Services which is obfuscated with some options off. We hope it will make the error disappear. Please try it and let me know if it works.

Thanks.

Yeah, it seems like it is a 64bit machine compatibility issue with this version. I used the older version of Aspose.Words (2.0.2.0) and that worked without any issues.

So what about the build I attached? Does it work?

Sorry, we fixed the issue by putting in an older version before we got your reponse with the new modified build. So, I am going to have to schedule a downtime or send out a notification to the users if I were to use your modified build. I’ll let you know how that goes.