Free Support Forum - aspose.com

Error Generating PDF : java.lang.ArrayIndexOutOfBoundsException


#1

Hi ,

This is regarding problem with Aspose slides, When I tried to generate PDF in the application
some times it is throwing java.lang.ArrayIndexOutOfBoundsException . Please find the log error
when we tried to generate the PDF file.Pleae find the error given below.

com.ibm.cet.services.Assets shareAsset Error generating pdf
java.lang.ArrayIndexOutOfBoundsException
at com.aspose.slides.Collections.Generic.List.get_Item(Unknown Source)
at com.aspose.slides.Collections.Generic.List$Enumerator.hasNext(Unknown Source)
at com.aspose.slides.vv.try(Unknown Source)
at com.aspose.slides.Presentation.(Unknown Source)
at com.aspose.slides.Presentation.(Unknown Source)
at com.aspose.slides.Presentation.(Unknown Source)

Pleae find the atttached source files. one is pptx file and the second source file is : java file which geneates the pdf file.

I am getting the error for the method private Presentation processPresentation(List components, List inStreams, InputStream headerFooterStream, List headerFooters, Map<Long, ImageObject> assetImages, String country, String locale, List<byte[]> attachments) throws Exception Attached rar file contains pptx file and CetDocProcessSlidesImpl.java file

Request to please give us the resolution for the same.

Thanks,


#2

Hi Laurie,


Thank you for your interest in Aspose.Slides.

I have observed your comments and worked with the presentation file shared by you. I have not been able to reproduce the issue. I have attached the generated PDF file for your kind reference. Please try using Aspose.Slides for Java 15.6.0 on your end and then share your kind feedback with us. If you still face the issue then please share with us the environment details on your end so that I may investigate it further on my end to help you out.

Please let us know if the issue persists. We will be happy to assist you further.

Best Regards,

#3

Hi,
when I try to generate pdf using aspose, I’m also getting java.lang.ArrayIndexOutOfBoundsException.
Please find the details below.

java.lang.ArrayIndexOutOfBoundsException: 3
at com.aspose.pdf.Table.lf(Unknown Source)
at com.aspose.pdf.Table.lI(Unknown Source)
at com.aspose.pdf.l11u.lI(Unknown Source)
at com.aspose.pdf.l11u.le(Unknown Source)
at com.aspose.pdf.Page.lf(Unknown Source)
at com.aspose.pdf.Page.lk(Unknown Source)
at com.aspose.pdf.ADocument.processParagraphs(Unknown Source)
at com.aspose.pdf.Document.processParagraphs(Unknown Source)
at com.aspose.pdf.ADocument.lf(Unknown Source)
at com.aspose.pdf.ADocument.lj(Unknown Source)
at com.aspose.pdf.ADocument.lj(Unknown Source)
at com.aspose.pdf.ADocument.lf(Unknown Source)
at com.aspose.pdf.Document.lf(Unknown Source)
at com.aspose.pdf.ADocument.save(Unknown Source)
at com.aspose.pdf.Document.save(Unknown Source)

I’m unable to create a table which consists of >= 4 columns.

Thanks.


#4

@seems999,

Can you please share source file along with sample code and environment details so that we may further investigate to help you out.