We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error in getting Task items

Hi, when trying to download Task items using the following code, I get this error for many many items:
MapiProperty [Lid:‘PidLidTaskAcceptanceState’:0x812A:Integer32:00062003-0000-0000-c000-000000000046] has invalid value: NoMatch

What does the error mean? It’s a problem of the item or of the component? We use it to download and backup items of mailboxes, so we need to know how to solve it.
Thanks and best regards.

string msgUri = "......" // the uri of the task item.
var currTasks = service.FetchMapiTasks(new List<string> { msgUri }); // service var is the IEWSClient instance.

Hello @albertose,

Can you try to call the FetchItems or FetchItem method for any problematic task item? Is the error reproduced with this method?
Also, if possible, send us some task sample (as .msg file) on which you faced the error.
Thanks.

Hi @DmitryS , thanks for quick answer.
While you were replying, I was doing another test and tried to use the overload of the method that accepts custom PropertyDescriptor list.
It gives the same error even if I have excluded the property PidLidTaskAcceptanceState from the list… maybe the library doesn’t run correctly the overload and always load all the properties?
Please check and let me know, in the meanwhile I’ll try your fix.
Unfortunately I cannot send msg because I still didn’t manage to download anything, it just gives error.

This is the code:
var currTasks = service.FetchMapiTasks(new List<string> { msgUri }, defaultTaskProperties );
and this the property list:
public static PropertyDescriptor[] defaultTaskProperties = new PropertyDescriptor[] { PropertyDescriptor.GetInstance(34062, PropertyDataType.Boolean, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34071, PropertyDataType.Time, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34070, PropertyDataType.Time, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34130, PropertyDataType.Integer32, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34132, PropertyDataType.String, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33026, PropertyDataType.Floating64, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34054, PropertyDataType.Boolean, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34049, PropertyDataType.Integer32, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34051, PropertyDataType.Boolean, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34064, PropertyDataType.Integer32, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34068, PropertyDataType.Boolean, new Guid("00062008-0000-0000-c000-000000000046")), //PropertyDescriptor.GetInstance(33066, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), // ****** PropertyDescriptor.GetInstance(33040, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33057, PropertyDataType.String, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33052, PropertyDataType.Boolean, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33029, PropertyDataType.Time, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33041, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33068, PropertyDataType.Boolean, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33062, PropertyDataType.Boolean, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34072, PropertyDataType.Integer32, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33060, PropertyDataType.Boolean, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33059, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33055, PropertyDataType.String, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33065, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33063, PropertyDataType.String, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33028, PropertyDataType.Time, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33043, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33025, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33042, PropertyDataType.Integer32, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(33027, PropertyDataType.Boolean, new Guid("00062003-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34208, PropertyDataType.Time, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34209, PropertyDataType.String, new Guid("00062008-0000-0000-c000-000000000046")), PropertyDescriptor.GetInstance(34239, PropertyDataType.Time, new Guid("00062008-0000-0000-c000-000000000046")) };

PS: tried with FetchItem, same error and same behaviour also using custom property array. It seems like the additional PropertyDescriptor list parameter is ignored.

@albertose,

Thanks for the quick response.
I think custom PropertyDescriptor list did not help, because PidLidTaskAcceptanceState is always present for the task.
I have created the EMAILNET-40914 ticket. We’ll try to create a task and reproduce the issue. We’ll keep you informed. Thanks.

Hi @DmitryS ,

if you want and if it can be useful, I can send you the XML returned from the request, that I managed to extract with another software that intercepted the return data from the Exchange server.
Another question: where can I keep track of this ticket status? always here on this topic?

if you want and if it can be useful, I can send you the XML returned from the request, that I managed to extract with another software that intercepted the return data from the Exchange server.

Of course, any information will help us find the problem’s root quickly.

Another question: where can I keep track of this ticket status? always here on this topic?

Yes, you can track the ticket status in this topic.
Thanks.

Ok perfect, here’s the xml file of the downloaded task:
task.7z (2.2 KB)

Looking forward to your reply, as this issue doesn’t allow us to backup Task items.

@albertose,

Looking forward to your reply, as this issue doesn’t allow us to backup Task items.

Ok, thanks.

Hi @DmitryS , any news about the issue?

@albertose,

Your ticket is still under review. Thank you for understanding and patience.

Hi @DmitryS , are there any news about the issue above?
Sorry for rushing you, but we need to solve this problem as Task items are currently excluded from the backup, so it’s a quite big problem for us… let me know.
Thanks in advance.

Hello @albertose,

The issue has been resolved and will be included in the upcoming release to be published on 30-31 Jan.
Thank you for patience