Free Support Forum - aspose.com

Error Installing - #2869

Hi,

I've had the same error - 2869 when trying to install with both 4.4 and 4.3. Please let me know how to install!

I'm running Vista 64-bit, is that why it won't install? Is there anything I can do?

Mike

Hi Mike,

Do you have administrator rights when installing Aspose.Cells?

Yes, I do. At the beginning of the installation, I get a User Account Control dialog, and I give Apose the Admin rights. No luck.

Even though Vista will do the “administrator prompt thing” shortly after install (if you just run the MSI), it is still not good enough for the installation to be successful. Please login with an administrator role then run the installer.

I am an Administrator on the machine as well, so that’s not it.

What’s the version of your vista? Has IIS installed on your machine?

It’s the final version, 64 bit, no IIS.

Our demos are web applications. So our installer will create virtual directories on IIS. That's the root of problem.

Please install IIS on your machine, then it will work fine. If it's impossible for you to install IIS, please copy this attached dll to your machine.

I installed IIS, then restarted, and still got the same error.

I found a workaround. Since the error was near the end of the installation, I copied all of the files before the installer deleted everything.

I'm testing out Aspose.Cells now, thanks for your help!