We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error occurred in JDK v.1.5

Dear Aspose Support Team

Good moring.

This is Heeyoung Jeong from Inchalbase South korea.

My customer bought Aspose slide for JAVA in Nov 2015 and use it

The end user developed Powerpoint slide convert to Image program using Aspose slide for JAVA.

While they use the developed program, there is an error occurred in JDK v.1.5 but it was working well with JDK v.1.6

Could you please let me know how to operate it in JDK v1.5

The End user system environment is as following;

- aspose.slides-15.8.0.jar
- JAVA Version
Server #1 : java version "1.5.0_22" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)
Server #2 : java version "1.6.0_45" Java(TM) SE Runtime Environment (build 1.6.0_45-b06)

Running error log ;

2016-01-13 13:53:00 [ACTIVE] ExecuteThread: '14' for queue: 'weblogic.kernel.Default (self-tuning)' ERROR - java.lang.NoClassDefFoundError: com/aspose/slides/License
java.lang.NoClassDefFoundError: com/aspose/slides/License
at *.createPptSlide(CS070250.java:266)
at *.service(CS070250.java:77)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:592)
at com.smd.infra.*.service(*.java:375)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:283)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:88)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3229)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2002)
at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:1908)
at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1362)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)

Thank you in advance and I look forward to hearing from you.

Hi Steve,


Thank you for your interest in Aspose.Slides.

I have observed your comments and like to share with you that Aspose.Slides for Java does not support JDK 1.5. It supports the JDK 1.6, JDK 1.7 and JDK 1.8. Please upgrade the JDK to work with Aspose.Slides for Java.

I hope this will clarify the concept. Please share if I may help you further in this regard.

Best Regards,

Thank you for your reply.



The end user have to use Aspose.Slides for
Java with JDK 1.5 becase they have plan for upgrade JDK later.

JDK 1.5 was able to use in Aspose.Slides
for Java 15.1 or 15.2.

So, could you please offer library or info regarding this?


Thanks and I look forward to hearing from you.

Hi Steve,


I have observed your comments and like to share with you that support for JDK 1.5 has been discontinued so I am afraid we may not offer latest versions of Aspose.Slides to work with JDK 1.5. You may use older releases which used to work with JDK 1.5 or upgrading the JDK would be the better option because latest version of Aspose.Slides are better in performance and with more bug fixes.

Please share if I may help you further in this regard.

Best Regards,

Hello,

I’ve download previous version 15.1 and 15.2 of Aspose.Slides but those were all compiled in JDK v1.6.

Could you please let me know how to get the library for compiling with JDK v.1.5?

Thanks and I look forward to hearing from you.

Hi Steve,

I have observed your requirements and like to share that now Aspose.Slides for Java has support for Java 6, 7 and 8. The support for earlier versions of Java before Java 6 is unavailable. Please visit this documentation link for supported platforms as well. Please share, if I may help you further in this regard.

Many Thanks,