Free Support Forum - aspose.com

Error : "A generic error occurred in GDI+" in Aspose.Word

Hi Guys.
I’ve discovered this error on my Asp.net 2.0 application that running on Windows 2003 R2 64bit.
Also, I have this line in my codes

doc.SaveOptions.ExportImagesFolder
(doc is a Document object)

If i remove this line, my website will work just fine.

Cheers.

Attached is the screenshot related to topic

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your inquiry. Would you please attach your document and code that will allow me to reproduce this issue? I will try to reproduce this problem and provide you more information.

Also please tell me which version of Aspose.Words you are using.

Best regards.

I’m using the latest Aspose.Words component. This error occured on Production server only, when i’m in development everythings seems fine.

Btw, it solved now.

i just change this line

doc.SaveOptions.ExportImagesFolder = Server.MapPath(“tempImages”)

to

doc.SaveOptions.ExportImagesFolder = “c:/inetpub/wwwroot/myWeb/tempImages”

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

It is nice that you already found the solution.

Actually it is strange because “Server.MapPath("tempImages")” should return the same path I think.

Best regards.

yeah. Thats correct. Both return the same result. But they’re react different on my problem.
I found this solution in another forum.