Error saving doc file on server (but OK on localhost)


I’m having problems creating Document records on the server (but it works locally). I have tested out permission on the local save directory by just doing a File.Create. However, I cannot save an Aspose document in that same directory:

Works on local and on server (win 2008):
File.Create(“C:\temp\bluePrintWebsiteTemp\test” + DateTime.Now.ToFileTimeUtc() + “.txt”);

Does NOT work on server:
Aspose.Words.Document resultDoc123 = new Aspose.Words.Document();
resultDoc123.Save(“C:\temp\bluePrintWebsiteTemp\test” + DateTime.Now.ToFileTimeUtc() + “.doc”);

What else can I try? I don’t know why I’d be able to save a regular file, but not an aspose generated file.



Thanks for your inquiry. Please note it is recommended to run Aspose.Words with Full Trust permission on shared server. Please check following documentation link for details. However, if the issue persists with appropriate Trust level permissions then please share some more details about the issue along with the environment details. We will look into it and will guide you accordingly.

Consideration when running on a Shared Server Environment


We run and manage the win 2008 server here ourselves, so I can check on anything else you suggest. I’ve tried putting in my web.config to see if that helps but it didn’t make any difference. Aspose runs fine on a different Win 2003 server.



Thanks for your inquriy. I am afraid I am not clear about your reply. You mean setting Full Trust level for application in web.config did not resolve the issue. You may compare the settings of the both servers, one that is working fine and other failing the application. However as requested earlier, if issue persists then please share a sample console application and your server environment details here. We will try to replicate the issue at our end and will guide you accordingly.


I took that same code and moved it to a win2016 server and it worked ok without any Full Trust requirements. Let’s close this for now.