We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error: The current configuration system does not support user-scoped settings As well

This is really a repeat of the other thread of the same name. I as well searched it and saw the error from 2011.


I really just wanted to provide a little more detail. Below is the line that generates the error on my system. Below that is the error and stack trace.

Thanks
Randy
var smtp = new Aspose.Email.Mail.SmtpClient(mail1.intermedia.net, 1025, "batch@transguardian.com", “mypassword”);

System.TypeInitializationException: The type initializer for ‘Aspose.Email.Mail.SmtpClient’ threw an exception. —> System.Configuration.ConfigurationErrorsException: The current configuration system does not support user-scoped settings.
at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)
at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)
at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)
at System.Configuration.SettingsBase.get_Item(String propertyName)
at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)
at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)
at Aspose.Email.Properties.Settings.get_SmtpDiagnosticLog()
at Aspose.Email.Mail.SmtpClient…cctor()
— End of inner exception stack trace —
at Aspose.Email.Mail.SmtpClient…ctor(String host, Int32 port, String username, String password)
at tg.objects.email.SendEmail(String sFrom, String sTo, String sSubject, Boolean bHTML, String sBody, ArrayList alAttachment, String cc, String bcc) in c:\inetpub\TransGuardian Website\tg.objects\email.cs:line 171

Hi Randy,

Thank you for posting your inquiry.

We have tested this issue at our end with the latest version of Aspose.Email for .NET 5.7.0 and a test Gmail as well as Exchange account, but no exception is raised. Could you please enable SMTP logging at your end and share the log details with us? It may help us investigate the issue further.

Have you tried it in a web application?


This is for a web application. I tried to enable logging, but the only instructions I can find are for non-web apps. Do you have instructions for web apps?

Thanks
Randy

Hi Randy,


I have re-produced the issue here and logged it under id: EMAILNET-34978 for further investigation by the product team. I shall write here as soon as some feedback is received in this regard.

I realize that you turned if over to development just last Friday, but I was hoping for some sort of update, timeline or workaround. Right now we are looking at cutting over some changes on our site and we are in a holding pattern until this is resolved. If it going to a while then I will try to move to an earlier version of Aspose email until I hear from you. If it only a day or two I will wait it out.


Thanks
Randy

Hi Randy,


I have checked the status of this ticket and found that it is planned to be resolved in our next release Aspose.Email for .NET 5.8.0. It will be released in the first half of Oct 2015. You will be automatically notified once the new product version is released and available online for download.

We are sorry for any inconvenience caused to you in this regard.

hi Muhammad,


We are having the same issue and currently evaluating your product.
In the last release of your library, you did a specific fix for us and we cannot
do the whole testing/presentation in this situation.

Could you provide us with a pre-release/unofficial build just to do our tests/presentation?

regards
Lyubo

Hi Lyubo,


Thank you for contacting Aspose support team.

Currently this new release is under QA process and cannot be provided for testing. You may please wait until this product is released and is available online for download. We are sorry for any inconvenience caused to you in this regard.

The issues you have found earlier (filed as EMAILNET-34978) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.