Free Support Forum - aspose.com

Error when I am using the Setlicense methods

Hi,

I recently upgraded to PDF.KET version 3.8 (from 3.4), when I am trying to set the license (total license). I am getting the following error

Could not load file or assembly ‘Aspose.Pdf.Kit, Version=3.4.0.0, Culture=neutral, PublicKeyToken=ae9e610db67fc2c1’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

I copied both the XML and DLL file from 3.8 version. I have embedded the license file in my project.

Thanks,
Nagendra

Hi Nagendra,

Please remove any existing DLL/XML files from the project. Remove any old references using Remove option after right clicking the Aspose.Pdf.Kit reference in References under your project. Do Not build the project yet. Add reference to the new 3.8 DLL in the project. Now, rebuild your project.

I hope it’ll be working fine. However, if you still find any problem, please do let us know.
Regards,