We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error when writing a mpp file that was read from a mpp file

Hi,


Aspose tasks Java 17.1.0.

When I try to read then write the attached MPP file with aspose - even without doing any change to it - I’m getting an exception.

Code:

/* Snipped license code out */

Project asProject = new Project(“C:\temp\qwerty.mpp”);
asProject.save(“c:\temp\output.mpp”, SaveFileFormat.MPP);


Stacktrace:

Exception in thread “main” com.aspose.tasks.TasksWritingException: Project writing exception.
at com.aspose.tasks.brf.a(Unknown Source)
at com.aspose.tasks.czd.a(Unknown Source)
at com.aspose.tasks.czd.a(Unknown Source)
at com.aspose.tasks.Project.save(Unknown Source)
at AsposeParseMppFile.main(AsposeParseMppFile.java:41)
Caused by: com.aspose.tasks.TasksWritingException:
Writing task with UID=‘0’ started.
Writing tasks fixed data started.
Writing tasks fixed data finished.
Writing tasks variable data started.
reference type or nullable type required
at com.aspose.tasks.bkm.a(Unknown Source)
at com.aspose.tasks.brf.a(Unknown Source)
at com.aspose.tasks.brf.q(Unknown Source)
at com.aspose.tasks.brf.l(Unknown Source)
… 5 more


I tried saving the MPP file as MSP 2007 format in Microsoft Project first but it produces the same result.
Hi Jay,

Thank you for your inquiry and sharing details.

We have investigated the issue. Initial investigation shows that the issue persists. The issue has been logged into our system with ID TASKSJAVA-338. Our product team will further look into it and provide feedback. We will update you with the feedback in this forum thread once available.