We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error while loading ppt with Embedded Object

Hi,
I am using the Aspose.slides & Aspose.cells version 17.6.
I have written a sample code to create a ppt and embed an excel object isdie it was mentioned in the documentation Link
The ppt gets generated and when i double click on the object it opens the corresponding Excel Worlbook.
However after thatI cannot exit from the Workbook. The ppt gets distorted in the sense it magnifies and shows excel contents on the slide partly.
PFA zip containing the screenshot for the behaviour.
Is it limitation of evaluation version?
OLE embed in ppt issue.zip (678.1 KB)

@rishi1989,

I have observed your comments. Can you please share sample files and sample project so that we may further investigate to help you out.

Hi,
PFA eclipse project for the same
Please add the Aspose.sldies & Aspose.cells 17.6 jars into the libs folder in the project and configure it on the build path, As I cannot upload the jars in the project due to size limitation.

EmbedExcel.zip (41.3 KB)
On running the AsposeEmbedExcelInPppt java file a presentation
with the name “OleEmbed.pptx” will be created in the folder “src/main/resources/output”.

Right now the project contains the generated ppt as well. You can rerun if you need to verify.

Any updates?

Any updates?

@rishi1989,

I have worked with source file and source code shared by you using Aspose.Slides for Java 17.6 and have been able to observe the issue. A ticket with ID SLIDESJAVA-36497 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.

We are sorry for your inconvenience,

Please increase its priority. We need to decide on purchase of the license.
Also its not a complex issue, its a very basic thing that an embedded excel is not opening properly in a ppt.
May be something I have missed in code.It should not be a product issue as its very basic.
Please look through my code once again if need be and get back at the earliest

@rishi1989,

I have observed your comments. Actually issue has been added recently in our issue tracking system and our product team is investigating issue in details. I request for your patience till the time further feedback is shared by our product team and issue gets resolved. We will share good new with you soon.

We are sorry for your inconvenience,

Thanks, any estimated time for accomplishment

@rishi1989,

I have discussed the issue status with our product team and like to share that concerned issue is blocked owing to missing implementation in Aspose.Slides for .NET, so this issue first will be resolved in .NET and than in Aspose.Slides for JAVA. I also requested our product team to share further feedback regarding this issue. We will also share ETA with you once detailed investigation is completed by product team.

Thanks for the reply.
I have a concern here. It was a simple test I carried out from the sample code shared in your documentation.
Was the code not unit tested before posting in the documentation?
Not really understanding how can this be an issue, its just like the happy path is failing without any complex tests involved.
May be something I have missed in the code, I would request you to please get it reviewed from any experts in your team again. Because its hard to believe that such a simple scenario is failing, hence the concern

@rishi1989,

We are sorry for your inconvenience.

The issue that you have shared needs to be investigated as there is no exception or any error thrown while adding Ole frame to slide. I also suggest you to please try adding XLSX as OLE object in a PPTX presentation to observe the behavior. For XLSX, you will be needed to use Excel.Sheet.12 in class name while adding Ole frame.

I had already tried with it but still same issue. SaveFormat was used as XSLX and worksheet was also an .xslx file

@rishi1989,

In that case, I request you to please wait till the issue is resolved by our product team.

Okay, you can try altering the size of the window it gives some different results.
May be this helpful for investigating

@rishi1989,

We will share the feedback with you as soon as the feedback will be shared by our product team.

Any updates? I know issue has been raised and its in progress.
Still can you please escalate this and get it done on priority.
Its one of the major blocker for purchasing the license.
The scenario is not complex, its unfortunately a code in the documentation that doesn’t work

@rishi1989,

I have observed your comments. I regret to inform that issue is still unresolved. I have also increased issue priority from medium to high. I have also requested our product team to resolve issue as soon as possible. However, the issue is internally blocked owing to other issues in Aspose.Slides for .NET. I also like to inform that you can get paid priority support and please visit these guidelines for your convenience.