Evaluation on german VB.Net 2010


#1

Hi, I just wanted to evaluate the latest version of Aspose.cells on my german version of VB.Net 2010 pro. After finishing the installation of the latest msi file with no errors, I tried to add a reference to a new project based on framework 4.0. .Because there was no entry in the .NET section of the references, I tried to add these references manually. Now there are 2 problems. In the directory for .Net 4.0 there is no GridDesktop DLL and after adding the DLLs from the .Net 2.0 directory, I can not find any control in the toolbox. Is Griddesktop not supported any more under .Net 4.0 or is threre another problem?


#2

@markeisele,

Thanks for your query.

We do not provide .NET 4.0 compiled Dll for Aspose.Cells.GridDesktop, we only provide the component compiled on .NET 2.0. But you may use Aspose.Cells.GridDesktop (from .NET 2.0) in your .NET framework 4.x project, it will work fine.

You need to add the GridDesktop control manually by yourself, see the document for your reference:
https://docs.aspose.com/display/cellsnet/Integrate+Aspose.Cells+Grid+Controls+with+Visual+Studio.NET

Also, see the Aspose.Cells.GridDesktop Docs here:
https://docs.aspose.com/display/cellsnet/Aspose.Cells.GridDesktop

You may also check the Examples at Github repos.

Hope, this helps a bit.


#3

Hi, thanks for the quick answer. I added the dlls like decribed in the above article, but there is nothing new in the toolbox until I click the menu item “show all”. Now the grid item are shown, but geyed out. (see attached screenshot)Aspose_01.JPG (10.9 KB)


#4

@markeisele,

Could you please share a sample application (runnable) so that we can analyze and provide our feedback.


#5

Hi, there is no sample application, because I can not even write a sample as long as I do not manage to get the grid control into the toolbox! The actual problem is, that the grid control only appears in the toolbox when I create a new project based on Framework 2.0. If the new project is based on Framework 4.0 the grid control is greyed out and there is no possibility to write a sample application.


#6

@markeisele,

I am not sure why it is not working on your end when using .NET Framework 4.x. Which VS.NET project template type, you are using? I am using Windows Forms Application project template type with .NET framework 4.5.2 as target .NET framework when I create a new project in VS.NET 2015. I have tested it in a simple project. Please find attached the zipped archive containing the WinForm project which you may open into VS.NET and run and it will work fine. Also find some screenshots for your reference:
https://i.imgur.com/LIILEn6.png
https://i.imgur.com/LeQM7Uj.png
https://i.imgur.com/HymCdyx.png
testapp1.zip (4.7 MB)


#7

Hi, I tried to open your Testapp. I could not run the example, because I have not installed Frameword 4.52, but the controls where shown in the toolbox. Then I tried it again with Framework 4.0 and the controls where greyed out again.2018-12-07_11-25-45.jpg (256.4 KB)


#8

@markeisele,

That is strange as we still could not find your issue. I have created another project (it has a single form on which I have pasted/dragged the Aspose.Cells.GridDesktop on it), its target framework version is 4.0. Please find it attached and open it into VS.NET and run it. Or directly run its portable executable file (i.e., WindowsApplication1.exe from “\testapp1\WindowsApplication1\WindowsApplication1\bin\Debug” folder).

It looks like an issue with your VS.NET or due to your environment. I use VS.NET 2015 (english) to create the project. If you still find the issue, kindly provide complete details on your environment (e.g OS, VS.NET, .NEt Framework version, etc.) and capture a video to demonstrate all the steps and show the issue, we will check it soon.
testapp1_new.zip (4.8 MB)


#9

Hi, that´s also strange!! When I open your project on my VS Installaiton (VS2010 pro on Win 8.1 with Framework 4.0 installed) it works. The controls in the toolbox are enabled and under project references the aspose dll is listed as first item.
I´ll try to find out what the problem is with the project I created. I´ll give you a feedback as soon as I have a solution.


#10

@markeisele,

Please take your time. Hopefully you will figure it out on your end.