We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Evaluation Only. Message on Document Page

Hello.

I have purchased Aspose.Words and got license file. I am receiving 'Evaluation Only' Message while running application.

Sunil

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

Please refer to this thread, information under heading Licensing:

If this doesn’t help please describe the steps you are performing to load the license and what environment you are using. The more information you provide the faster we can find a resolution.

Regards,

Hi.

I am working on Linux. These are the step taken to sucessfully running application.

InputStream fstream=null;

fstream=getClass().getResourceAsStream("/home/sunil/capexweb/Aspose.Words.lic");

com.aspose.words.License license=new com.aspose.words.License();

try {

license.setLicense(fstream);

}

catch (Exception f) {

}

License file is available /home/sunil/capexweb

Sunil

Hi Sales.

I had purchased Aspose.Words , received License file which is not working. I am just waiting for the reply. I don't know why Aspose is silent .

Sunil

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Have you checked the following points?

  • Make sure your call to SetLicense gets executed. Step through in the debugger.
  • Make sure your code does not catch and silence an exception thrown by Aspose.Words licensing code. For example, Aspose.Words will throw if it cannot find the license.
  • Make sure the input documents do not already have the evaluation message. Aspose.Words does not delete existing evaluation messages.
  • Make sure SetLicense is executed before you instantiate any Document object.

Best regards.

Yes , I have checked whatever you suggested. I had tried to change License File also and received exception.

Sunil

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Could you please tell me what kind of exception is thrown? Please provide me stack trace.

Best regards.

Hello.

Problem is solved Now.

Sunil