We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Examples dashboard behind a proxy server

Do you know how I can get the examples dashboard to work behind a proxy server? Thanks.

Hi Marc,

Thanks for your inquiry. Please supply us with the following information.

We will investigate the issue on our end and provide you more information.

Best regards,

I am trying to open the .NET version of the Aspose.Words example dashboard. I work for a very large organisation which uses proxies all over the place (specifically, .pac files). I’m on Windows 7 64-bit. Thanks.

Hi Marc,

Thanks for reporting this issue to us.

Could you please let us know the exact place of the error or problem you are facing when you run the dashboard behind a proxy? For instance, can you get the actual application downloaded and running after executing the clickonce installer or is that not even possible? Also is there any error message or log you can post here?

Cheers,

When I double-click on the following exe, this is the error I get:

C:\Program Files (x86)\Aspose\Aspose.Words for .NET\Examples\ExamplesDashboard.exe

An error occurred trying to download ‘https://github.com/aspose-words’.

See the setup log file located at ‘C:\Users\myusername\AppData\Local\Temp\VSDD9D0.tmp\install.log’ for more information.

Here is the text of the log file:

The following properties have been set:
Property: [AdminUser] = true {boolean}
Property: [ProcessorArchitecture] = AMD64 {string}
Property: [VersionNT] = 6.1.1 {version}
Running checks for package ‘.NET Framework 2.0 (x86)’, phase BuildList
Running external check with command ‘C:\Users\myusername\AppData\Local\Temp\VSDD9D0.tmp\DotNetFX\dotnetchk.exe’ and parameters ''
Process exited with code 1
Setting value ‘1 {int}’ for property 'DotNetInstalled’
Reading value ‘Version’ of registry key 'HKLM\Software\Microsoft\Internet Explorer’
Read string value '9.0.8112.16421’
Setting value ‘9.0.8112.16421 {string}’ for property 'IEVersion’
The following properties have been set for package ‘.NET Framework 2.0 (x86)’:
Property: [DotNetInstalled] = 1 {int}
Property: [IEVersion] = 9.0.8112.16421 {string}
Running checks for command 'DotNetFX\instmsia.exe’
Result of running operator ‘ValueExists’ on property ‘VersionNT’: true
Result of checks for command ‘DotNetFX\instmsia.exe’ is 'Bypass’
Running checks for command 'DotNetFX\WindowsInstaller-KB893803-v2-x86.exe’
Result of running operator ‘ValueExists’ on property ‘Version9x’: false
Result of running operator ‘VersionLessThan’ on property ‘VersionNT’ and value ‘5.0.3’: false
Result of running operator ‘VersionGreaterThanOrEqualTo’ on property ‘VersionMsi’ and value ‘3.0’: true
Result of checks for command ‘DotNetFX\WindowsInstaller-KB893803-v2-x86.exe’ is ‘Bypass’
Running checks for command ‘DotNetFX\dotnetfx.exe’
Result of running operator ‘ValueNotEqualTo’ on property ‘DotNetInstalled’ and value ‘0’: true
Result of checks for command ‘DotNetFX\dotnetfx.exe’ is ‘Bypass’
’.NET Framework 2.0 (x86)’ RunCheck result: No Install Needed
Launching Application.
URLDownloadToCacheFile failed with HRESULT '-2147024891’
Error: An error occurred trying to download ‘<https://github.com/aspose-words>’.

Hi Marc,

Many thanks for posting the log here. If the PAC file is associated with the Internet Explorer then it should work, as long as their isn’t any further authentication required. Could you try opening Internet Explorer and from there navigating to the address on the log: https://github.com/aspose-words. Does this work and if so does it require you to enter the username/password?

I have attached the actual application to this thread, could you try running the executable and see if you have any luck with the actual .NET application itself?

Thank you for your help.

Thanks. The attached zip file contains a lot more than the 471KB ExamplesDashboard.exe on my computer. It runs and opens but as soon as you click on Aspose.Words, it complains about a connection error (no doubt because our proxy server requires authentication).

And to answer your question, that link to github did require me to authenticate with my usual username/password to get through our proxy server (the first time I load IE, that is; throughout the day if I keep IE open then further browsing within IE does not prompt for my password again). I believe it’s normal practise for other processes to have to authenticate when using the same proxy settings in IE -i.e., they can’t simply “piggy back” onto my existing - authenticated - IE browser window’s session.

Hi Marc,

Thanks for this information. Actually it sounds like a simple .NET application calling a WebRequest should be able to piggyback on the default credentials of IE like that, however while ClickOnce picks up the proxy info used in IE, it seems to not handle the authentication unless you are using NTLM or some other pass-through authentication such as using the default credentials i.e Windows Integrated Security and the Windows account information. Unfortunately Clickonce doesn’t offer any other way to specify a proxy when installing or updating.

Going forward the best alternative is an external link to a manual installer and to add a space for users to enter a proxy into the dashboard itself. This of course will take some time to plan and implement, so for the time being I believe it would be easier for you to download the samples manually from Github.

Note if you can manage to get the proxy working from inside Visual Studio and for its add ons then we do provide an plugin that contains the same examples and the same sort of user experience as the dashboard. You can find it here. Please try this otherwise please try downloading directly from Github by selecting a repository and clicking “Download ZIP” on the right hand side.

Our apologies for any inconvenience.

Cheers,

I had the same problem (with .NET version of the dashboard).

What worked for me was create a ExamplesDashboard.exe.config file in the same folder of ExamplesDashboard.exe (which is quite hidden, in my PC is %LOCALAPPDATA%\Apps\2.0\RB12TLGQ.ELO\K9PBZJXG.4BC\exam…tion_b9824cf4a33426e5_0001.0000_0eefd7563a864523)

The config file is as follow

<?xml version="1.0" encoding="utf-8" ?>

Microsoft documentation for the System.Net section in config files can give further options, in my case setting useDefaultCredentials to true was enough.

Aspose could consider create such a file in the installer of the dashboard, or even better allow some proxy configuration from the dashboard itself.

Hi there,

Thanks for your suggestion and for your research into this issue, it’s much appreciated. I will add this config file to the installer so those using default credentials (which I believe are the same as what is used for proxy in IE) can access the dashboard.

We will consider a screen to enter in custom proxy configuration in the long run.

Cheers,
Adam