We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Excel file formatting

After we export to excel the cells that contain date cannot be reformatted via Format Cells. Could you help me with this?
This message was posted using Aspose.Live 2 Forum

Hi Anthony,

Can you please explain the issue a little more. Also, please share your code and template file with us. This will help us to understand the issue.

Thanks,

I have attached the EXcel output. If you select a cell with a date within the cell

For example - Column G Row 2 and right click and select Format Cells > Date and try to change the formatting it wont change to the new selected format

Hi,

Well, I think you so called date values might be in string format, they should be numeric to implement Date formatting.

How did you create such file and how did you import the data. Did you use Cells.ImportDataTable() method, I think you may try to use the overloaded version i.e…,
http://www.aspose.com/documentation/.net-components/aspose.cells-for-.net/aspose.cells.cells.importdatatable_overload_2.html

Remember to specify the date time string (e.g “m/d/yy”) in the second last parameter and put “true” for the last parameter.

If you still find any issue, kindly do create a sample code segment/application to show the issue,we can check it soon.

Thank you.