Free Support Forum - aspose.com

Excel to PDF results missing text

Dear Support,

I’m using the latest version to convert Excel to PDF and we’re running some issues with missing text. I am not sure what is cause it and i attached the excel and converted pdf file here for you to check if you can help fix it.

thanks/kevin
1786.zip (354.7 KB)4802.zip (351.5 KB)

@ksheng,
I have tried to convert these files to PDF using MS Excel and observed that it generates similar PDF (with missing text) as generated by Aspose.Cells. Hence it does not seem to be an issue with the Aspose.Cells but issue with the sample Excel files. You may please try to convert these files to PDF using MS Excel and share the feedback.

thank you for your reply. I opened the excel files and save them as pdf file and they all look ok with data in the pdf file.

I attached the output here for your reference.
Convered using Excel SaveAs PDF.zip (24.7 KB)

My Office version is Microsoft Office 365 ProPlus, not sure if you have same version.

@ksheng,
Thank you for sharing the sample output and other details. We have logged a ticket for further investigation of this issue and will write back here once any update is ready for sharing.

This issue is logged as:
CELLSNET-47889 - Text missing during Excel to PDF conversion

@ksheng

Actually, there are more than one sheets in the source file, but sheet tabs is hidden. You can show sheet tabs in Excel by “File->Options->Advanced->Show sheet tabs”: sheet_tabs.png (142.4 KB)

If you printview entire workbook, the result is smilar to our generated:print_entire_workbook.png (58.9 KB)

Your shared Microsoft Excel generated pdf file only outputs the active sheets:print_active_sheet.png (67.1 KB)
You can using the following code to get the same result:

Workbook wb = new Workbook("178634802.xls");

int activeSheetIndex = wb.getWorksheets().getActiveSheetIndex();
for(int i = 0; i < wb.getWorksheets().getCount(); i++)
{
    if(activeSheetIndex != i)
    {
        wb.getWorksheets().get(i).setVisible(false);
    }
}

wb.save("output.pdf");