Free Support Forum -

Exception: "Index was outside the bounds of the array" on loading MPP file (C#)

We are currently using Aspose.Tasks version 18.7.1. When we try to open a customer’s MPP file we get an “Index was outside the bounds of the array.” error. The error comes as TasksReadingException exception and attached is the log (AsposeErrorLog1871.txt in zip).

I upgraded to the latest version of Aspose.Tasks off Nuget (19.6.1) and still get the error. However it no longer comes as a TasksReadingException but is caught as a generic exception and the stack trace is attached (StackTrace1961.txt in zip).

I can email the MPP to support if needed. I’d rather not attached to this thread for anyone to grab though. (8.8 KB)


Can you please share source file so that we may further investigate to help you out.

I sent the file over private message to you. Did you get it?


I have worked with source file shared by you and have been able to observe the issue. A ticket with ID TASKSNET-3342 has been created as in our issue tracking system to further investigate the issue. This thread has been associated with ticket, so that you can be automatically notified as soon as this issue is resolved.

The issues you have found earlier (filed as TASKSNET-3342) have been fixed in this update.