We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Exception on loading PPT file (.NET Core)

Please advise me.

Exception is thrown when I am going to read attached .ppt file hello.zip (26.2 KB)

with the Message “No data is available for encoding 1252. For information on defining a custom encoding, see the documentation for the Encoding.RegisterProvider method.”

.Net core 2.1/Aspose.Slides 19.5.0

using Aspose.Slides;
Presentation pres = new Presentation("hello.ppt");

FYI: This will not happen when you read any other pptx file ( or even WORD/EXCEL file using Aspose.Word/Aspose.Cells ) prior to very the line above in the same process.

I’d like to know why this happens.
And please let me know whether you sugget “to read a dummy safe pptx data at the beginning of the process earlier than any other file loading” as a workaround for this issue, or not.


I have worked with source file shared by you using Aspose.Slides for .NET 19.7 and unable to observe any issue. Can you please try to use Aspose.Slides latest version on your end and share feedback with us if there is still an issue.

Would you try this sample app, build with Apose.Slide for .NET 19.7? ConsoleApp1.zip (97.9 KB)

In this project you will face the exception I reported.
If not, please kindly advise me which data/procedure I should share with you in order to reproduce the issue.


I have worked with source file and have been able to observe issue. A ticket with ID SLIDESNET-41366 has been created in our issue tracking system to further investigate to resolve the issue. We will share good news with you soon.

Hi, I’m facing the same issue as above with the ppt files. For pptx it works fine. Using Aspose.Slides for .NET 19.7.0


I have verified the issue status from our issue tracking system and like to share that the issue has just recently been added and is pending for investigation in our issue tracking system. We will share good news with you as soon as the issue will be fixed.

Hi, mudassir.fayyaz

Is there any better / reasonable way you suggest?


I regret to share that at present the issue is pending for investigation in issues queue. We request for your patience and will get back to you as soon as it will be investigated.

OK. Thanks anyway.

Any update on this issue?


I have verified the issue status and like to share that concerned issue has been resolved in previous version. Can you please try using latest version Aspose.Slides for .NET 20.1 on your end and share with us if there is any incurring issue.

Hi, It’s working fine with the latest version. Thanks


Thank you for sharing the feedback.