Free Support Forum -

Exception: The license signature is invalid on loading license file (Java)


We’re developing a Java Spring project that relies on Aspose PDF, Words and Imaging, but we’re facing some license issues. In order to load the license (we have an Aspose.Total license), we placed the .lic file in the root folder of our project and, in the application main method, we’re doing the following:

new com.aspose.pdf.License().setLicense("Aspose.Total.Product.Family.lic");
new com.aspose.words.License().setLicense("Aspose.Total.Product.Family.lic");
new com.aspose.imaging.License().setLicense("Aspose.Total.Product.Family.lic");

The first two lines work fine (no errors are generated and the results of the corresponding APIs don’t show the Aspose watermark), but the third one throws the following exception:

class com.aspose.imaging.coreexceptions.FrameworkException: The license signature is invalid.
com.aspose.imaging.License$a.a(Unknown Source)
com.aspose.imaging.License.setLicense(Unknown Source)

Where are we doing wrong? Can you suggest us how to properly load the license in a Spring application? Is it different for Aspose.Imaging?




Can you please visit this documentation link. This will help you out to resolve your issue. Please share feedback with us if there is still an issue.

Thank you for the quick reply.
As you can see from the first post, we are already doing what is stated in the documentation section that you have indicated (more precisely, like in the Example 1). Today we have also tried the Example 2 way, but the result is still the same.
The only difference is that we are using an Aspose.Total license, whereas in the examples an Aspose.Imaging license is used. Nevertheless, the same line works for the PDF and the Words modules, so we cannot get why it doesn’t work for the Imaging module.


I have observed the issue shared by you and there seems no issue in code sample. Can you please try loading the license only for Aspose.Imaging in your application and commenting the other license loads. Please share this feedback with us and if there is still an issue please also provide us the license file that you are using to reproduce the issue on your end. I also like to add further that we have a method, License.IsLicensed() which returns true if license is properly applied otherwise it return false. You can also consider using this option in your application as well.

We tried to load the license only for Aspose.Imaging but it doesn’t work neither.
We sent you a message with the license. Thank you in advance.


I have worked with the license file shared by you and it seems to be an issue. An issue with ID IMAGINGJAVA-1303 has been created in our issue tracking system to investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Thanks! Could you tell us when do you expect to release this fix?


I have verified from our issue tracking system and like to share that the issue is tentatively going to get resolved in Aspose.Imaging for .NET 19.6. We will share the feedback with you as soon as the issue will be fixed.

Are there any news about this issue? I’m sorry to bother you again, but my boss is pressing me. By the way, why did you say that the issue is going to be resolved in Aspose.Imaging for .NET 19.6? Aren’t we talking about Java?


The concerned issue has also been marked as resolved for Aspose.Imaging for Java 19.6 too. We will share the good news with you as soon as the product will be available online.