Free Support Forum - aspose.com

Exception"XML content not provided" while loading PNG images using Aspose.Slides for .NET

Loading attached png-image results in an ArgumentNullException.

com.aspose.imaging.internal.Exceptions.ArgumentNullException: Xml content not provided
Parameter name: xml
com.aspose.imaging.internal.hG.h.(Unknown Source)
com.aspose.imaging.internal.hG.j.(Unknown Source)
com.aspose.imaging.internal.loaders.PngLoader.load(Unknown Source)
com.aspose.imaging.Image.a(Unknown Source)
com.aspose.imaging.Image.b(Unknown Source)
com.aspose.imaging.Image.f(Unknown Source)
com.aspose.imaging.Image.load(Unknown Source)
asposeImaging.Main.main(Main.java:19)
— End of inner exception stack trace —
com.aspose.imaging.Image.a(Unknown Source)
com.aspose.imaging.Image.b(Unknown Source)
com.aspose.imaging.Image.f(Unknown Source)
com.aspose.imaging.Image.load(Unknown Source)
asposeImaging.Main.main(Main.java:19)

sample code:
Path path = Paths.get(“c:/temp/2000x4000px.png”);
byte[] filecontent = Files.readAllBytes(path);
Image.load(new ByteArrayInputStream(filecontent));

2000x4000px.zip (657 Bytes)

King regards, Josef

@dvtdaten,

I have worked with the source file shared by you and have been able to observe the issue. An issue with ID IMAGINGJAVA-915 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed. We will share good news with you soon.

The issues you have found earlier (filed as IMAGINGJAVA-915) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by mudassir.fayyaz