We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Exchange Web Services Supported For Exchange 2007 SP1?

I am using Aspose.Email to connect to an Exchange mailbox using the ExchangeWebServiceClient. When I run the code and try to connect to an Exchange 2007 instance, I receive the error "The request failed with an empty response."

This site is also using an ISA server that I have to go through, but I have other code that uses Exchange Web Services outside of Aspose.Email at this same site and it has no problems connecting. I simply have to set my ExchangeVersion property to Exchange2007_SP1.

From what I read in these posts, it seems you want us to use the WebDav method with 2007, do I understand that correctly, or is there a way to use the ExchangeWebServiceClient with Exchange 2007?

The Aspose.Emal version I am using is 2.3.0.0.

I just tried version 2.6.0.0 and I get the same result.

Hi Joe,


Thanks for writing to Aspose.Email support team.

I have analyzed the information and need more assistance to identify the problem.

Could you please give a try to the latest version Aspose.Email for .NET 2.8.0 and send us the feedback if same problem is observed.

You may also try to use ExchangeClient class, which uses WebDAV protocol to connect to the Exchange Server and hence can be used with any version of Exchange Server on which WebDAV is enabled e.g. Exchange 2000, 2003 or 2007.

If still problem persists, please arrange some test account on the said exchange and send us the credentials along with a sample console application which can be used to reproduce the issue here. It will help us to identify the problem and assist you as soon as possible.



I get the same response from 2.8.0.0.

I have since discovered that our code is functioning at another site utilizing Exchange 2007, so I think the Exchange version is not the issue.

Thank you for your assistance, I will post another message if necessary.

Kashif, on this server where I get the mysterios reply, there is a proxy they are going through. In my Exchange Web Services code wich works (not the Aspose code), I don’t see where I am specifcally specifying any proxy information, yet it works. Is there some property I need to set in my Aspose code to tell it to use the proxy infromation?

Hi Joe,


The ExchangeClient and ExchageWebServiceClient in Aspose.Email API has a property for setting the proxy. Could you please try it at your end and see if that solves the issue (You can try both ExchageClient and EWS)? If the problem still persists, could you please provide us the credentials for a test account on the same server for our analysis of the problem? We’ll look into this issue further and assist you further.