Expecting: 250. Recieved: 334 VXNlcm5hbWU6


#1

When trying to send an email using our production server (running X-mail) I get the following error:

Aspose.Email.SmtpException: ERROR - Expecting: 250. Recieved: 334 VXNlcm5hbWU6

I assume it’s something to do with the authentication.
I have tested the account details with a standard e-mail client and they work fine and it works perfectly on my development machine (ms exchange server)
Is there something else I need to do to get this to work?
Thanks.


#2

Hi

Yes - you are very likely correct with the authentication diagnose.
Is this an email server accessable from the outside? Reason being that I would like to attempt that myself to diagnose the problem. If you could set up a working test-account for me, it would proberly make diagnosing a lot easier…?

Send the information directly via email to my emailaddress.

Thanks!


#3

excellent, the new update allows me to send emails Beer


#4

Hi,

I have just downloaded the latest version of Aspose.Network and get exactly this error.

I am using an authenticated SMTP server and don't get the issue when using a non-authenticated server.

I have tried this manually with telnet and 'auth login' and it works fine. What do I need to do to fix this?

Chris


#5

Dear Chris,



Could you share your code and give me one address and account to trace the problem?



Please sent to my email guangzhou # aspose.com



Feel free to ping me with any problems.



thansk very much.


#6

Have done that.


#7

Dear Caustin,

Thanks for considering Aspose.

We have sent you the hotfix for this problem. Could you please give it another go?

Feel free to ping me with any problems.

Thanks very much.


#8

That fixed it, thanks,

Chris


#9

Dear Chris,

We have released an offical hotfix for the problem you inputted previously. And another new enhancement is also included in the latest hotfix dll.

Please get it from our website

http://www.aspose.com/Downloads/Aspose.Network/2.3.1.0/Default.aspx

the release note:

http://www.aspose.com/Community/Blogs/kyle.huang/archive/2006/04/11/45877.aspx

Feel free to access me if any problems.

Thanks