Export dwg to pdf with proper font (bold)

saved_man.zip (889,7 kB)
The uploaded zip file contains the dwg and the exported pdf. Although the DWG file contains the style “SLDTEXTSTYL0” whose font is bold “Century Gothic”, “SLDTEXTSTYL1” is a normal Century Gothic style. In the exported PDF, however, it appears that the bold “Century Gothic” style is used. What could be the reason for this?
saved_almostGood.zip (67,6 kB)

I uploded an "almast good PDF. The difference is clearly visible, we can ignore the colors now.

could you please try whether this example is helpful:

  using (CadImage cadImage = (CadImage)Aspose.CAD.Image.Load(fileName))
      CadRasterizationOptions options = new CadRasterizationOptions();
      options.DrawType = CadDrawTypeMode.UseObjectColor;
      options.PageHeight = 150;
      options.PageWidth = 150;

      options.Quality = new RasterizationQuality
          TextThicknessNormalization = true,

      PdfOptions pdfOptions = new PdfOptions();
      pdfOptions.VectorRasterizationOptions = options;

      cadImage.Save(fileName + ".pdf", pdfOptions);

Thanks for the quick reply, but it hasn’t changed. “SLDTEXTSTYL1” is also the normal “Century Gothic-bold” style. But no, it shouldn’t be that, but “Century Gothic” normal, without bold.

it seems not to be bold (because bold is definitely more thick), but I agree that it looks a bit more thick than expected. We have created CADNET-9803 to investigate this case deeper. It could be helpful for us if you can provide code examples to generate both initial pdf and “almost good” sample too.

sorry for the late answere.
“Almost good” sample was direcly generated from a CAD softwere wit Save as PDF command. we have no influence on it. But this PDF is not good for us, becouse is not possible maintain layer information.
That’s why we save CAD drawing to DWG and we would like to convert to PDF with layer information to PDF.
It look like that text high era alos a little bit higher than in the original. “Century Gothic” with 10 font high a little bit higher in the generated PDF with aspose.

Thank you for the details, will look at this.