We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Export to PDF Word wrap problem

I am using the latest Aspose Cell v7.4.3. The following simple code loads a simple excel spreadsheet containing merged cells with word wrap. When exported to PDF, some of the words got cutoff. My actual worksheet is more complicated so I am using this simple worksheet to illustrate the problem.


Dim license1 As New Aspose.Cells.License
license1.SetLicense(“C:\Devl\Tools\ASpose Cell\v7.4.3\Aspose.Cells.lic”)
Dim wk As New Workbook(“C:\Devl\Book1.xlsx”)
Dim pdfFile As String = "C:\Devl\Book1.pdf"
wk.Save(pdfFile, SaveFormat.Pdf)

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

Please download and try the latest version: Aspose.Cells
for .NET v7.4.3.4
. It works fine as we have tested it.

We have attached the output pdf for your reference.

I can’t seem to see any difference in the result using your updated files. I copied the DLL and TLB files to C:\Program Files (x86)\Aspose\Aspose.Cells for .NET\Bin\net2.0 folder, and re-establish the project reference to v.7.4.3.4 and the resultant pdf is the same. What am i missing?

Hi,


Well, I have also tested your issue with v7.4.3.4 (as my fellow colleague shared the download link), it works fine with it. I have attached my output file (please download the attached file and open the file into Adobe reader), I used your template file as an input file to re-save it to PDF format.

I suspect either you might not be using the latest fix i.e. v7.4.3.4 or the relevant fonts are not installed on your pc/system (So, you should install all the fonts to avoid such issues).

Could you try to add a line to your code to confirm if you are using the correct version or not, e.g
Console.WriteLine("Assembly Version Info: " + CellsHelper.GetVersion());


If you still find the issue, kindly give us more details about your OS, environment, .NET framework version, architectural type: 32 bit or x64, a sample console application etc. We will check your issue soon.

Thank you.

Hi, i used the GetVersion() function and it's indeed using v7.4.3.4. I don't quite understand what you mean by installing the fonts? I changed the xlsx file in question to use Arial font for the merged cell and perform the conversion again into pdf. The same issue persists. I am performing the same task on the same PC. If the xlsx file is able to use Arial font, the font can't possibly be missing right?

My environment is Windows 7 64 bit, Visual Studio Pro 2008, the Excel file is created using Excel 2007. The .NET framework is v2.0. The project in question is a Web application (.aspx). To isolate this issue, I created a new aspx page with one button with those codes to load and save. See attached.
Hi,

Thanks for the sample files and some details.

We think, this issue is caused by default font that is not set in Excel. And, in different environments, different default fonts will be used. Please set the default font in MS Excel for your file or use Aspose.Cells APIs, e.g you should set the default font using PdfSaveOptions while rendering your file to PDF, see the sample code below:

Sample code:

Workbook book = new Workbook(@"E:\test2\Test1.xlsx");
PdfSaveOptions pso = new PdfSaveOptions();
pso.DefaultFont = "fontName";
book.Save(@"E:\test2\testout.pdf", pso);

If you still find the issue, could you give us the details, what default windows dpi settings are set on your PCs? We will further evaluate your issue.

Thank you.

Tried both setting default font in Excel and using code, but still no difference. The DPI on my system is: "Medium - 125% (default)"


Note that I also have an older version of Aspose Cell on the same system, but my project is not referencing it.

Hi,


Please set it to “100% (default)” and let us know your result.

Thank you.

Doesn’t help.

Hi,


This is really strange.

Anyways, please find attached the zipped archive that contains two Excel workbooks. Please do:
1) Open both files into your MS Excel at your mentioned PC(s), re-save the files and send them back to us.

2) Please convert the files (workbooks) to PDF in MS Excel manually and send them back to us.

We will check your issue further.

Thank you.

Please see attached.


Hi,


Thanks for your provided files archive.

I have logged a ticket with an id “CELLSNET-41739” for your issue. We need to investigate your issue based on your updated files. Our concerned developer will look into it and evaluate your issue soon.

Once we have any update on it, we will let you know here.

Thank you.

Any updates? I realized that when I deployed my application to the UAT server, there is no issue when converting to PDF. It happens only on my development machine. What is the governing factor when it comes to conversion to PDF?

Hi,

Thanks for your posting and using Aspose.Cells.

We are afraid, there is no update for you at this moment. However, we have logged your comments. Please spare us some time. Once, we will have some update for you, we will let you know asap.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.5.2.2

Your issue should be fixed in it.

Let us know your feedback.

Thank you.