Free Support Forum - aspose.com

ExportDocumentStructure not working with large documents like 600 pages with Aspose version 18.8

Hi

Aspose Issue Version: 18.8
Issue Brief Description: Not able to create tags for large PDF documents.

I am facing an issue on tags with Aspose version 18.8 for PDF documents, when the size of the exported PDFs is big, approximately 600 pages in our case.

When I tried using PdfSaveOptions.setExportDocumentStructure(true); with Aspose version 18.8,
tags are generated for the first line only, in the document and nothing is generated for the rest of the document. For smaller documents, say 100 pages, tags are generated correctly though. Please refer to the attached screenshots that explain the above scenarios.600pages tags docs.zip (113.1 KB)

For the same case of large document above, a previous version is working fine. I tried the same 600 pages document with Aspose version 17.6 and it generated the correctly tagged PDF document.

It seems that the latest version 18.8 is not able to handle larger documents with the code snippet mentioned above. Can you confirm this understanding? If this is a valid issue, can you please suggest a workaround or a solution to this problem?

Thank you.

Hi

Please find attached sample code for reference which replicates the issue.
Zip file has

  • Input Docx file
  • Output pdf file with no tags generated
  • Sample java code

Sample code for issue.zip (1.3 MB)

Thanks

@cvsformulary

Thanks for your inquiry. We are investigating this issue and will get back to you soon.

@cvsformulary

We have logged this problem in our issue tracking system as WORDSNET-17436. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi
I have one more question on this : Why do we have empty containers in the tags for blank spaces.
Please refer to the screenshot Structurerd PDF.zip (24.2 KB)

. Is there any way to avoid that. Can’t the whole word come in one line.

@cvsformulary

Thanks for your inquiry. We have logged this problem in our issue tracking system as WORDSNET-17510. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi Tahir,

Is there any date till when these issues will be resolved. We have plenty of issues that are logged which we need to deliver in our coming releases. Do you know till when Aspose will be able provide the fixes for all the issues logged by us.

Thanks

@cvsformulary

Thanks for your inquiry. We try our best to deal with every customer request in a timely fashion, we unfortunately cannot guarantee a delivery date to every customer issue. We work on issues on a first come, first served basis. We feel this is the fairest and most appropriate way to satisfy the needs of the majority of our customers.

Currently, your issue WORDSNET-17436 is under development phase. We will inform you via this forum thread once it is resolved.

Your second issue (WORDSNET-17510) is pending for analysis and is in the queue. Once we complete the analysis of your issue, we will then be able to provide you an estimate. You reported this issue in free support forum and it will be treated with normal priority. To speed up the progress of issue’s resolution, we suggest you please check our paid support policies from following link.
Paid Support Policies

@cvsformulary

Further to my previous post, hopefully, the fix of WORDSNET-17436 will be available in November 2018 release. Please note that this estimate is not final at the moment. We will be sure to inform you via this forum thread as soon as this issue is resolved. We appreciate your patience.

Thanks Tahir for the update. Just wanted to confirm since status of WORDSNET-17436 is closed, can we expect the fix in Nov Aspose.words jar. This is one of the major issue which is preventing us to upgrade the Aspose.words version to the current one It will be great if we could get this sooner.

And do you have any expected date for WORDSNET-17510. It seems the issue is affecting the size of the PDF.

@cvsformulary

Thanks for your inquiry.

Yes, this issue has been resolved and its fix will be available in next version of Aspose.Words i.e. 18.11. This release will be published at the start of next month.

This issue has been postponed. Please note that this is not a bug in Aspose.Words. It is an enhancement feature. We will inform you via this forum thread once there are any further developments.

The issues you have found earlier (filed as WORDSNET-17436) have been fixed in this Aspose.Words for .NET 18.11 update and this Aspose.Words for Java 18.11 update.