We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Extracting Bitmap-Attachments from Outlook-Msg fails

Hi,

Iam using Aspose.Network.dll to extract outlook attachments. This works fine for Mails without bitmap as attachments. When I try to extract bitmap-attachments Iam getting a wrong file back.
I have attached a sample project to reproduce this issue. Their are 2 outlook messages withoutBitmap.msg and withBitmap.msg at “applicationpath\mails”. If you start the application, select one of the two files from the listbox and press the GetAttachment-Button. Do the same with the other file and compare the results.

You will need to add Aspose.Network.dll to "applicationpath\lib"

Could you please tell why this happens?

Many thanks in advance

Scheu

Hi Scheu,


Thanks for your inquiry.

I have reproduced this issue at my end and also logged this in our bug tracking system (ID: 21039). We will look into it and will inform you when it will be fixed. Sorry for the inconvenience.

Hi,

are there some news related to this issue?

Kind Regards

Hi,

This issue has been fixed and will be included in the coming release, hopefully at the end of this month.

The issues you have found earlier (filed as 21039) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Hi,


Please note that in RTF formatted MSG file, the embedded images are represented as Ole objects and have the same name (Picture (Device Independent Bitmap)) and do not have extension.