Free Support Forum - aspose.com

Fields missing in concatenated PDF form

I use pdfEditor.Concatenate to concatenate several PDF forms into one. On the resulting PDF (result.pdf in the attachment), fields are missing on some of the pages.

I'm using Acrobat 9 to read these files.

Any assistance will be greatly appreciated.

Hi Eric,

Could you please help us identify the particular fields which are missing from the output PDF file? This will help us focus on the particular problem area. Kindly share your findings in detail with us, so we could investigate the issue accordingly.

We’re sorry for the inconvenience and appreciate your cooperation.
Regards,

Hi Shahzad,

All the fill-in fields are missing on page 4, 9, 11, 12 & 13 in the result.pdf..

Eric

Hi Eric,

Thank you very much for sharing further details. I have tested this issue using latest version, but couldn’t reproduce it at my end; the fields are present in the output file on the mentioned pages. Please download the latest version of Aspose.Pdf.Kit for .NET and try at your end. I have also attached the output file with this post, for your reference. Please have a look and see if there is still some issue with the output file.

I hope this helps. If you have any further questions, please do let us know.
Regards,

Hi Shahzad,

Thank you for looking into this issue. But when I view the output file, fields are missing on page 3 & 11-14. Please tell me which PDF viewer you are using. I'm using adobe acrobat 9 pro extented version 9.0 and adobe acrobat 8 standard version 8.1.2.

Thanks,

Eric

Hi Eric,

You’re right. I have also noticed that some of the pages are still missing the fields. I have used Adobe Acrobat and Adobe Reader to view the output PDF file. I have logged this issue as PDFKITNET-26944 in our issue tracking system. Our team will look into this issue and you’ll be updated via this forum thread once it is resolved.

We’re sorry for the inconvenience.
Regards,

Hi Shahzad,

Do you have an ETA when this problem will be resolved? This problem is holding up a new system from going live. I would really appreciated if I can have a firm ETA so I know what to tell my boss.

One more thing. I’ve been getting occasionally the “Evaluation Only. Created with Aspose.Pdf.Kit. Copyright 2002-2011 Aspose Pty Ltd.” message when filling in a PDF form using Pdf.Kit. Please tell me what I need to do to get rid of that message.

Thank you,

Eric

Hi Eric,

Our team still needs to investigate this issue in detail. However, I have asked the development team to share the ETA of this issue. You’ll be updated via this forum thread once the ETA is available.

As far as your issue with evaluation mark is concerned, it looks like you have got a license and still get the evaluation watermark sometimes. Could you please share the scenario where and when exactly the evaluation mark appears? In addition to that, please make sure you have verified the following points at your end:

Did you make any changes in your application recently?
Have you moved the application to a new location?
Where are you setting the license file – in some Global file/method?
Do you think this file has been replaced with some other file recently?
Could you please also see that the code which sets the license is not commented out?
The code which sets the license is not executed conditionally?
Also, could you please make sure that your application is able to find your license file?
Are you catching some exception where license is set?
If yes, what exception it is?

Please share any further details of your findings about the situation, so we could further investigate it at our end.

We’re sorry for the inconvenience and looking forward to help you out.
Regards,

Hi Eric,

Our team has looked into the issue logged as PDFKITNET-26944 and I would like to share with you that the fix for this issue will be available at the end of September or early October 2011. You’ll be notified via this forum thread once it is resolved.

Regards,

The issues you have found earlier (filed as 26944) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.