Free Support Forum - aspose.com

File corrupt (needs repair) after presentation load and save

I am using Aspose.Slides 15.4.0 jdk17. Also tried with:

- Aspose.Slides 15.4.0 jdk16
- Aspose.Slides 15.3.0 jdk17
Running this code corrupts the presentation and PowerPoint asks for a repair every time it’s opened:

PATH = “some/path/template.pptx”;
SAVE_PATH = “some/path/new_pres.pptx”;

Presentation pres = new Presentation(PATH);

pres.save(new FileOutputStream(SAVE_PATH), SaveFormat.Pptx);

Hi Stefan,

I have observed the issue shared by you and request you to please provide source presentation, generated presentation and complete PowerPoint version with which you are able to reproduce the issue. I will investigate the issue further on my end to help you out.

Many Thanks,

Hi Mudassir,

Sorry for the late reply.

I have provided the source presentation and the generated one.

My PowerPoint version on Mac:

Microsoft PowerPoint for Mac (Preview)
Version 15.10.0 (150508)

It has also been tested on Windows, but I am unable to provide the version now. If you need it I will get it for you.

Hi Stefan,

I have worked with the presentation file shared by you and have been able to observe the issue specified. An issue with ID SLIDESJAVA-34905 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-34905) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hey, i tested new version 15.6.0 this problem is not resolved. My power point version is 2007, i tested and other versions.

Hi Stefan,

I have observed your comments and like to share that your issue has been reported for PowerPoint in Mac as per this thread link. Can you please share the PowerPoint 2007 version with which you are reproducing the issue as I will be needing to investigate and log separate ticket for this in our issue tracking system.

Many Thanks,

Hi Mudassir


We’ve tested this on Mac with Office 2016 (PPT 15.13.1), Windows 7 with Office 2010 (PPT 14.0.7153.5000 32-bit) and Windows 10 with Office 2016 (Office 365 version 15.0.4737.1002 32-bit).

On each version, the source template (master) opens successfully, and the file generated by Aspose Slides fails to open (repair dialog).

The code used is as simple as:

// license aspose library...
Presentation pres = new Presentation("/tmp/source.pptx");
pres.save("/tmp/generated.pptx", SaveFormat.Pptx);

It does NOT matter if this code is executed on our Linux server (JBoss on RHEL) or on our development machine (Mac OS X 10.10.5). We used Aspose Slides 15.6.0.

I can send you the source and generated files by mail if you want? Can't post them as they are confidential...

Regards

Daan Kets
Development Manager
Delta Source

Hi Daan Kets,


Thank you for sharing the feedback. Can you please provide the presentation generated using Aspose.Slides for Java 15.6.0 that fails to open. I will investigate the things on my end to help you further.

Many Thanks,

Hi Mudassir


Did you have the chance to look at the files I submitted? We’re really hoping for a quick fix here…

With kind regards

Daan

Hi Daan Kets,

I have observed the posts shared by you in this thread and have not been able to find any presentation attachment in this thread. Can you please first try using Aspose.Slides for Java 15.6.0 on your end first. If there is still an issue then please provide the source presentation, sample code and generated output with us for further investigation on our end. Please share the requested information so that I may help you further in this regard.

Many Thanks,