We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

File format error tag in GIF metadata appears on saving (C# .NET)


I am using Aspose.Imaging 20.5.0 for .NET netstandard library and encountered the following problem:
I simply tried to load and save a GIF image and surprisingly a new tag was put into the file’s metadata that I was not intended to insert in. I checked the metadata with exiftool.

Code snippet:

static void myFunction(string inPath, string outPath)
using (Image image = Image.Load(inPath))

Error: File format error

I would be grateful if you could give me some help about what causes this issue and how it could be fixed.

Tamas Boldizsar

file.zip (5.7 MB)


Using Aspose.Imaging for .NET 20.6, I am unable to reproduce the issue. Can you please try using the suggested version on your end.

Thank you for your advice. I tried it, but no change at me… Using Aspose Imaging for .NET 20.6, the unwanted “Error” tag is inserted to the file properties the same. Tried with licensed and unlicensed libs as well. I also attached a screenshot of the exiftool command output from my terminal.
Any other suggestions?

test_metadata.zip (54.3 KB)


I can observe “File format error” tag in the shared image and in order to investigate it further a ticket with ID IMAGINGNET-3980 has been created in our issue tracking system. We will share the feedback with you as soon as the issue will be fixed.


Great, thank you very much! I am looking forward to your feedback.


We will keep you posted with feedback as soon as it will shared after resolution.


Can you please try using latest Aspose.Imaging for .NET 21.3 on your end and share if there is still an issue incurring on your end.


There is no more issue using the library you advised. I am very grateful for you, thank you for your work!


Thank you for sharing the feedback. We will close the ticket based on your feedback.