Free Support Forum - aspose.com

Filled Radar Graph hidden Axis Ticks on ToImage

When saving a filled radar graph with Value Axis tick marks to a emf image, the tick marks are not showing where the graph is present. It seems like a layering issue as the ticks do show where the graph is not. I have attached a zip of the xlsx file and the emf image that is created. the ticks show correctly in the xlsx file. Here is the code I used to create these files.

Dim workbook As Workbook = New Workbook
Dim worksheet As Worksheet = workbook.Worksheets(0)
Dim chartIndex As Integer = worksheet.Charts.Add(Aspose.Cells.Charts.ChartType.RadarFilled, 1, 4, 35, 12)
Dim chart As Aspose.Cells.Charts.Chart = worksheet.Charts(chartIndex)

worksheet.Cells(0, 0).PutValue(1)
worksheet.Cells(1, 0).PutValue(2)
worksheet.Cells(2, 0).PutValue(1)
worksheet.Cells(3, 0).PutValue(2)
worksheet.Cells(4, 0).PutValue(1)
worksheet.Cells(5, 0).PutValue(2)
worksheet.Cells(6, 0).PutValue(1)
worksheet.Cells(7, 0).PutValue(2)

chart.NSeries.Add("A1:A8", True)

chart.NSeries(0).Area.FillFormat.SetTwoColorGradient(System.Drawing.Color.Red, System.Drawing.Color.White, Drawing.GradientStyleType.FromCenter, 2)

chart.NSeries(0).Area.FillFormat.GradientFill.SetGradient(Drawing.GradientFillType.Radial, 90, Drawing.GradientDirectionType.FromCenter)

'Chart Area Settings
chart.ChartArea.Border.IsVisible = False
chart.ChartArea.Area.FillFormat.Type = Drawing.FillType.None

'Plot Area Settings
chart.PlotArea.Border.IsVisible = False
chart.PlotArea.Area.FillFormat.Type = Drawing.FillType.None

'Value Axis Settings
chart.ValueAxis.MaxValue = 2
chart.ValueAxis.MinValue = 0
chart.ValueAxis.MajorTickMark = 0.2
chart.ValueAxis.MinorUnit = 0.2
chart.ValueAxis.MajorGridLines.IsVisible = False
chart.ValueAxis.MinorGridLines.IsVisible = False
chart.ValueAxis.TickLabelPosition = TickLabelPositionType.None 'Do not show label
chart.ValueAxis.MinorTickMark = TickMarkType.Cross

'Category Axis Settings
chart.CategoryAxis.MajorGridLines.IsVisible = False
chart.CategoryAxis.MinorGridLines.IsVisible = False
chart.CategoryAxis.IsVisible = False
chart.CategoryAxis.TickLabelPosition = TickLabelPositionType.None 'Do not show label
chart.ShowLegend = False

chart.ToImage("FilledRadar.emf",System.Drawing.Imaging.ImageFormat.Emf)

workbook.Save("FilledRadar.xlsx", Aspose.Cells.SaveFormat.Xlsx)

Thanks

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have evaluated your issue and we were able to replicate this issue using the latest version:
Aspose.Cells
for .NET v7.3.3.2

using the following sample code.

We have logged this issue in our database. Once the issue is fixed or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41169.

Below is a sample code and I have attached the output png image for your reference.

C#


Workbook workbook = new Workbook(path);


Worksheet worksheet = workbook.Worksheets[0];


Chart ch = worksheet.Charts[0];


Bitmap bmpChart = ch.ToImage();

bmpChart.Save(path + “.out.png”, ImageFormat.Png);

Output Png Chart Image:

Hi,

Thanks for using Aspose.Cells.

You are right, it was because of layering. We have fixed this issue.

Please download and try this fix: Aspose.Cells for .NET v7.3.3.3 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-41169) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.